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TERRAIN EDITOR 

Visitor 3 Personal Edition for ArmA II 

(BI Tools v2.5.1) 

The manual assumes that you have to run the terrain editor. 

TIP: To access the terrain editor while reading this manual, open the terrain editor then switch between 

these pressing the left Alt+Tab keys. 

NOTE: The abbreviations used here: 

• LMB (Left Mouse Button) 

• MMB (Middle Mouse Button/Mouse Wheel) 

• RMB (Right Mouse Button) 
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INTRODUCTION 

The Visitor3 is terrain editor delivered by Bohemia Interactive studio with deferent package versions: 

The package versions BI Games 

BI Tools ArmA (Armed Assault) 

BI Tools 2 and BI Tools 2.5 ArmA / ArmA 2 

BI Tools 2.5.1 ArmA / ArmA 2 / Operation Arrowhead 

 

1. INTERFACE 

Main toolbar 

 
TIP: To get better idea on terrain, turn on Show shadows button. 

 

 
  



 

2. TOOLS 

2.1 Natural Objects 

The natural objects are defined here. The Natural objects button is used to hide or show them on a map. 

To access the natural objects, select Tools > Natural Objects 

Options: 

• Add/Browse… - the option adds an object, browse the opening list to select the P3D model you 

want to use. 

NOTE: the maximum name length of artificial objects has to be up to 50 characters. 

• Randomize size interval – a model size will be randomly set in the given interval when placed in 

Visitor. 

• Randomize angle interval – a model angle will be randomly set in the given interval when 

placed in Visitor. 

• Randomize orientation interval – a model facing direction will be randomly set in the given 

interval when placed in Visitor. 

NOTE: Randomization during insertion occurs as well for objects placed by a script. 

 

2.2 Artificial Objects 

The artificial objects are defined here. The Artificial objects button is used to hide or show them on a 

map. 

To access the artificial objects, select Tools > Artificial Objects 

• Add/Browse… - the option adds an object, browse the opening list to select the P3D model you 

want to use. 

NOTE: the maximum name length of artificial objects has to be up to 50 characters. 

• Randomize size interval – a model size will be randomly set in the given interval when placed in 

Visitor. 

• Randomize angle interval – a model angle will be randomly set in the given interval when 

placed in Visitor. 

• Randomize orientation interval – a model facing direction will be randomly set in the given 

interval when placed in Visitor. 

NOTE: Randomization during insertion occurs as well for objects placed by a script. 

 

2.3 Roads 

Types and parts of a road are defined here. Crossroads are road parts which need to have suitable road 

types defined for each of their ending direction. 

To define a Road type: 

1. Go to Tools > Roads… 

2. In untitled dialog, one-click LMB the Add… button 

3. In next untitled window, input a road settings 

• Road – the tab defines main settings of this road type. 

• Straight Parts– the tab defines the straight parts of a road type. 

NOTE: Those parts have a certain length, for example: 6.25, 12.5 or 25 meters. 

• Curves – the tab defines the curved parts of a road type. 

NOTE: Those parts have a certain radius, for example: 25, 50, 75 or 100 meters. 

• Special Parts – the tab defines parts with special appearance like a T-shape. 

• Terminators– the tab defines parts that end a road. 

NOTE: Those parts have the suffix “konec”. 

4. One-click LMB on OK button to close the window with road settings 

5. One-click LMB on OK button to close the window with defined Roads and defined Crossroads 

NOTE: A name of a new road type will appear within Road networks list in Panel of Objects toolbox. 

  



 

2.4 Forests 

Contents of a forest are defined here. 

To define a forest type: 

1. Go to Tools > Forests… 

2. In Forests dialog, one-click LMB the Add… button 

Forest definition dialog: 

• Forest parameters section: 

o Name (type) of – self-explanatory 

o Outline: standard/special checks – these define a color of forest outline 

o Color: standard/special checks – these define a color of forest objects 

• Forest objects section – self-explanatory 

o Square-fill: – this defines the forest objects within square zone. 

o Square-:– this defines the forest objects on borders of square zone. 

o Triangle (+ – it is unknown. 

3. One-click LMB on OK button to close the Forest definition dialog. 

4. One-click LMB on OK button to close the Forests dialog. 

NOTE: A name of a forest type will appear within Woods (OFP) list in Panel of Objects toolbox. 

The number of forest types, that are used, significantly affects performance (especially the CPU load). 

 

2.5 Project Parameters 

Project parameters contain basic information about the project size. The most of settings is available 

when project is started. Later only Satellite Grid, Texture layers and Satellite grid calculator settings are 

accessible. 

 

2.6 Project Preferences 

The option defines a path to textures and objects (if these stored in a specific place) and other settings: 

• Folder – Textures field defines a path to the folder where all landscape textures are stored. 

• Folder - Objects field defines a path to the folder where all objects used in Visitor are stored. 

NOTE: All paths are saved relative in the map, so you have to maintain folder structure. 

 

2.7 Object Manager 

There are only two functions. 

NOTE: Visitor must not be connected to Buldozer when using these functions. 

In case size of LOD resolution or LOD geometry of a model changed, these functions are useful to give 

Visitor a updated object description or to fix object shifts in vertical axis, including recalculation of all 

objects to relative elevation to surface =0. 

 

2.8 Replace Objects 

The option deletes or replaces all instances of an object (models) from the map. 

 

 

3. EDITING MODES 

3.1 Artificial Objects 

To access artificial objects: 

1. View > Panel of Objects  

2. Select Artificial objects (F1) from the drop-down menu 

3. Select an artificial object 

4. One-click LMB on the map where you want to place it 

NOTE: The list contains artificial objects except roads. 

  



 

3.2 Natural Objects 

To access natural objects: 

1. View > Panel of Objects  

2. Select Natural objects (F2) from the drop-down menu 

3. Select an natural object 

4. One-click LMB on the map where you want to place it 

NOTE: The list contains natural objects except forests. 

 

3.3 Road Networks 

To create a key part of road: 

1. View > Panel of Objects 

2. In Panel of Objects toolbox, select Road networks (F3) from the drop-down menu 

3. In field below, select a road type you want 

4. One-click LMB on the map where you want to place this 

5. In the Type of key part {1. from 4} window. 

• Step 1: Select a type of a key part, one-click LMB on Next button 

• Step 2: Select a key part of a road, one-click LMB on Next button 

• Step 3: Set up parameters of a key part, one-click LMB on Next button 

• Step 4: Create a key point of a road, one-click LMB on OK button 

NOTE: You need to click Show roads button on the view toolbar to see created road parts on a map. 

 

To edit a road double-click LMB on a road. 

Settings of “Key part of road”: 

• Orientation of key part (direction A) - Direction the A end is facing, angles are only possible in 

10° per step. 

• Position X and Z - Position of the key part on the map. 

• Modify Dir. A/B – create/delete parts of a road in the A/B direction 

• Gen.Terminator - create Terminator or new key part at the end of certain direction. 

• All Parts Of This Direction - all parts from the key part to the end of the road 

NOTE: 

- Deleting or adding a part in the middle of the road changes also the rest of the road. 

-Added part will be inserted before the part selected in All parts of this direction list. 

• Delete - delete a selected road part 

• Straight Part - add the selected straight part to the road. 

• Left Curve - add the selected left curve section to the road 

• Right Curve - add the selected right curve section to the road 

• Special - add the selected special section to the road 

 

3.4 Key points 

To access key points: 

1. View > Panel of Objects  

2. Select Key points (F4) from the drop-down menu 

3. One-click LMB on the map where you want to place the key point 

NOTE: Same options as in Named Zones editing mode (see below). 

 

3.5 Terrain vertices 

To access terrain vertices: 

1. View > Panel of Objects  

2. Select Terrain vertices (F5) from the drop-down menu 

3. One-click LMB on the map where you want to place the terrain vertex 

  



 

Change height… 

 
 

• Change only - show only up when the selection has sea and land points. 

o ground (positive height) - only points over sea level will be changed. 

o sea (negative height) - only points below sea level will be changed. 

• Minimal Height - all points will set to the height of the lowest point of selection. 

• Median Height - all points will set to the median height of selection. 

• Maximal Height - all points will set to the height of the highest point of selection. 

• Average Height - all points will set to the average height of selection. 

• Height - all points will set to this height. 

• Transform into interval - take the current height profile of selection and stretch it into the given 

interval. 

 

Erosion: 

• nGens - number of generations of erosion. 

• washCoef – coefficient about how strong does water flow affect terrain. 

• sedimCoef - sediment coefficient about how fast sediments sink down and stay where they are. 

• sedimBase - sediment base about how much sediment is there from the beginning. 

• sedimEff - sediment effect, "wash out" resistance of terrain. 

• initRain - strength of rain. 

• steadyRain - How long does the rain last. 

• finalBlur - create a smoother surface. 

 

3.6 Background Images 

To access background images: 

1. View > Panel of Objects 

2. Select Background images (F6) from the drop-down menu 

NOTE: Only BMP format is supported. 

To set the background image In the Create background image dialog: 

1. Choose *.bmp file. 

2. Set coordinates X and Y for top left corner 

NOTE: For the image covering whole map, set both to 0. 

3. Set Width and Height of the image. 

Example: If the map is e.g. 10240x10240 meters and the image covers whole area, set Width 

and Height sizes to 10240. 

NOTE: You can use a few smaller images together to cover whole area, if the coordinates and 

sizes are set correctly. 



 
 

3.7 Named Zones 

To access named zones: 

1. View > Panel of Objects 

2. Select Named zones (F7) from the drop-down menu 

To name a zone one-click LMB on the selection box. 

Options: 

• Go To... - center view on selected zone. 

• Properties – open window (double-click LMB on the selection). 

• Select area under zone – select area that is under zone. 

• Select objects in zone - select objects that are in the zone. 

 

3.8 Named objects 

To access named objects: 

1. View > Panel of Objects 

2. Select Named objects (F8) from the drop-down menu 

Option: 

• Go To... - center view on selected object. 

 

3.9 Surfaces (OFP) 

To access OFP surfaces: 

1. View > Panel of Objects 

2. Select Surfaces (OFP) (F9) from the drop-down menu 

Options: 

• Terrain type – the type of selected terrain. 

• Surfaces - selected surface. 

• Textures - selected texture. 

NOTE: If set to "random selection" it will randomly choose one of the available textures. 

• Set texture onto area - set current texture on selected area. 

• Set surface onto area - set current surface on selected area. 

NOTE: The textures are set according to their probabilities. 

• Set terrain onto area - set current terrain on selected area. 

NOTE: The surfaces are set according to their definition. The same for the textures. 

• Change texture onto area - change texture in area to current selected texture. 

• Texture Analysis… 

 

3.10 Woods (OFP) 

To create/edit Woods (OFP): 

1. Go to View > Panel of Objects 

2. Select Woods (OFP) (F10) from the drop-down menu 

3. Drag a selection box on a map where you want place forest. 

4. One-click LMB an Area forestation button. 

5. In Create forest dialog, set up follow: 



• Control parameters of forest section: 

o Type of forest: - this defines a name of a forest type 

o “Smooth” convex angles check box – self-explanatory 

o “Smooth” concave angles check box – self-explanatory 

o Generate parts with bushes around forest – self-explanatory 

o Cancel selected area after forest creation – self-explanatory 

6. Click OK button to close the Create forest dialog. 

NOTE: This tool for a creating of forests is obsolete and kept only for backwards compatibility in 

Operation Flashpoint maps. 

 

4. SCRIPTS 

Visitor 3 allows you to use scripts. Script files have the extension .VIS. For all commands see the Visitor 

Script Command Reference. 

 

5. PROJECT STRUCTURE SETUP 

It is important to store a project in the correct location. 

P:\CA\ < project_name> folder 

The naming of the project folder matches convention is tag_projectname: 

• The “tag” should be a short term which refers to you. 

• The “project name” is a term that describes the current project. 

The folder name should have no spaces or special characters, and only one underscore between the tag 

and project name. 

This naming convention must be adhered to for all the add-ons that you create, not only for maps. 

 

1. Unpack content of buildings.pbo, misc.pbo, plants.pbo and rocks.pbo into P:\CA directory (by 

default) in order to be able to work with data in the real-time viewer Buldozer. 

NOTE: Do not the same with roads.pbo such as ODOL road model is not suitable for use in 

Visitor. Instead, use the MLOD road model supplied with the BI Tools. 

2. Create directories: 

• P:\CA\< project_name > 

• P:\CA\< project_name >\Data 

• P:\CA\< project_name >\Source 

3. Place in P:\CA\< project_name >\Data folder your surface texture files (the suggested format): 

• the textures <maptag>_<texturename>_detail_co.png. 

• the normal maps for the textures <maptag>_<texturename>_detail_nopx.png. 

• the image of map project ui_selectisland_<mapname>_ca.png 

• the files <texture_name>.rvmat (for ArmA II series) 

When Bulldozer is first start, it creates the Layers folder In directory P:\CA\< project_name >\Data. 

This folder contains 

• segments of the surface map (“satellite map”) 

• segments of the layer mask 

• the *.rvmat files for each segment of the surface map (for ArmA II series) 

generated by Visitor 

4. Place in P:\CA\< project_name >\Source folder the following 

• Your reference file layerlegend.png 

• Your surface map (“satellite map”) sm_<map_name>_lco.png (the suggested format). 

• Your layers mask lm_<map_name>_lca.png (the suggested format). 

• Your file layers.cfg 

5. Create directory P:\CA\< project_name >\Source\Terrain 

6. Place in the Terrain folder your source map files, for example, a high map *.xyz. 

  



 

6. PROJECT SETUP 

1. Go to Project > New (CTRL + N) 

Project parameters dialog:  

• Terrain grid size (elevation vertices). 

• Terrain cell size (meters) is distance between the elevation vertices in X and Y axis. 

• Terrain size (meters) = Terrain grid size x Terrain cell size. The result is calculated automatically. 

• Calculator button. 

Satellite grid calculator dialog: 

• Image size (pixels) is corresponding to size of your surface (so called “satellite”) map. 

• Image resolution (meters/pixels) = Terrain size / Image size. The result is calculated 

automatically. 

• Segment size (pixels)  

• Segment size (meters) = Segment size x Image resolution. The result is calculated automatically. 

• Segment overlap (pixels) 

• Segment overlap (meters) = Segment overlap x Image resolution. The result is calculated 

automatically. 

• Calculated (cells): = (Segment size (m) - Segment overlap (m)) / Terrain cell size (m). The result is 

calculated automatically. 

• Proposed: = The result is calculated automatically. 

• Segment overlap (proposed): = The result is calculated automatically. 

2. Press Apply proposed and Close buttons. 

3. Set 40 x 40 meters value in Texture Layers. It is the size of square into which the detailed 

textures are mapped. 

  
(See Making Satellite Texture and Mask) 

4. Tools > Project Preferences. 

 



Folder - Textures field:  

Specify path to folder, into which  

• The surface map (“satellite map”) segments, 

• The layer mask segments, 

• The files <texture_name>.rvmat (ArmA II series)  

will be generated by Visitor.  

5. Click OK button. 

NOTE: This setting is important for importing the surface map (“satellite map”) and the layer 

mask. 

NOTE: Textures may be generated to different folder and packed into separate PBO file. 

6. Project > Save as <your_project>.pew into P:\CA\Source (by default). 

 

6.1 Terrain Size and Grid 

Before starting up Visitor, the first step is to determine your map planning values. 

There are five values that need to be locked in before you continue. 

• Terrain grid size 

• Terrain cell size 

• Terrain size 

• Satellite Image Resolution 

• Satellite Image Size 

We can figure out the first three values by balancing this equation: 

Terrain grid size x Terrain cell size = Terrain Size 

The only limit here is that the Terrain grid size must conform to the sizes allowed by Visitor. 

This can be 16, 32, 64, 128, 256, 512, 1024, 2048 or 4096 vertices. 

Example: 

512 vertices x 50m = 25,600m 

1024 vertices x 10m = 10,240m 

2048 vertices x 25m = 51,200m  

Once we have chosen terrain size we can also plan the satellite image resolution. This can depend on 

the quality of your satellite image, and should be 1, 2, 4, 8, 16, or 32 m/px. You need to be aware of how 

large this final satellite image will be, which so Terrain size / Image resolution = Satellite Image. 

It is recommended 25000px as an upper limit. The processing times for an image this large can be quite 

long, and the resulting PBO add-on file size can be over 1GB. 

Examples: 

10240m ÷ 1m/px = 10240px  

51200m ÷ 4m/px = 12800px  

25600m ÷ 8m/px = 3200px 

These five planning values should be marked down somewhere and saved as they will come up again at 

various times during the map creation process. 

 

7. TERRAIN EDITING 

You have several ways to edit your height map: 

• Manually (like “Surfaces (OFP)” (F9)) - you change each of vertices individually. 

• Import templates (Project > Import Templates…) 

• Import a height map (Project > Import Terrain from XYZ) - ASCII file format containing space 

delimited X Y Z on each line, where XY is UTM and Z is in meters. 

NOTE: During import you can align data to top or bottom left and set target data dimension to 

crop data or extend area. 

• Import PNG Image (Project > Import from Picture) - import 8 / 16 bit PNG image 

NOTE: PBL config must be present (it's created automatically when you export PNG file in the 

same location). 

• In Buldozer (see below) 



NOTE: for import terrain operation (and any other large scale operations like this) it's recommended to 

disconnect Buldozer otherwise it takes really long time to process the map. 

 

8. TERRAIN IMPORT 

Visitor allows you create the terrain yourself but it allows you import one. 

Existing locations can be recreated in Visitor provided the correct GIS data. 

Typical source data includes: 

• DTED or DEM elevation data 

NOTE: Visitor 3 can't import of DEM files. But you can convert DEM files to XYZ files using third 

party software. This topic is not the subject of this manual, so it will be described separately. 

• Vector data (VMAP or ESRI shape files) for roads, vegetation, and buildings 

• GeoTiff or similar bitmap surface image 

Before it can be used by the Visitor, source data needs to be cropped to the area of interest and 

changed into the following formats: 

• Elevation Data in XYZ ASCII triplet format. 

• Satellite Image (or other texture data) as PNG 24-bit RGB format. 

• Vector Data as ESRI shape files 

 

Formats of imported files: 

1. *.xyz (the high map). It is created by special software, the high map generators. 

2. *.png (the terrain image) with *.pbl file (the terrain parameters). They are created by Visitor 

when it exports a terrain into picture. 

Import of *.png file with *.pbl file: 

• Project > Import Terrain from picture. 

• browse CA\<your_project>\Source\Terrain 

• select and open <your_terrain>.pbl file 

NOTE: The <your_terrain>.png have to be in the same folder, for *.pbl file points to it. 

Import of *.xyz file: 

• Project > Import Terrain from XYZ. 

• browse CA\<your_project>\Source\Terrain 

• Select and open <your_terrain>. xyz file 

TIP: Visitor can also export terrain to PNG, using menu Project > Export Terrain into picture... 

Sometimes it is handy to make raw terrain in Visitor and later smooth or alter in some raster editor. 

• Click Show contours icon 

NOTE: You can change contour range using Actual preferences tool, where it's possible to set 

both contour interval and minimum contour (in meters). 

Colors of sea, terrain elevations and contours can be set in  

View > Define configuration > Colors - height tab. 

Visible terrain elements can be set in View > View settings or directly by the buttons in main 

toolbar. 



 
 

The surface map (“satellite map”) and layer mask import 

NOTE: During import of the data the Buldozer should be disconnected from the Visitor. 

You need to import from Source folder the following:  

• surface map sm_<map_name>_lco.png 

• layer mask lm_<map_name>_lca.png 

• file layers.cfg 

• mapLegend.png file (not necessary to alter this file in other projects) 

NOTE: In Data folder these files for each texture should be prepared: 

• <maptag>_<texture_name>_detail_co.paa - a detailed texture with normal map together 

replaces the surface map and MCO map segment on close range; 

• <maptag>_<texture_name>_detail_nopx.paa- normal map for detailed texture 

• <maptag>_<texture_name>.rvmat 

• <maptag>_middle_mco.paa - an optional map segment replaces the surface map on middle 

range. 

These surfaces have corresponding definition of so-called clutter (grass, plants or stones) generated 

automatically on respective surface by the game engine, unless the surface is overlaid by some model's 

Roadway LOD. 

To import: 

1. Tools menu > Import satellite & mask command 

2. The Select layer configuration file dialog: In the Source folder select layers.cfg file and press 

Open button. 

3. Rvmat selection dialog: In the Save .rvmat files as: field Binary default value. Press OK button. 

4. Select satellite map dialog: Select surface map and press Open button. 

5. Select layer mask dialog: Select layer mask and press Open button. 

The Importing Satellite Data box will display the import progress. After import, you should see Layers 

folder in the directory P:\CA\<your_project>\Data. The surface map segments and layer mask segments 

(*.png) and *.rvmat files for every surface map segment are stored in this folder. 

NOTE: It is not necessary to delete its content when you regenerate the segments. Visitor is capable to 

regenerate and replace only changed segments. All the new *.png files should be converted to *.paa 

files when Buldozer is started. Before you do so, it is recommended to save the project since it bears 

actual UV coordinates for the segments. 

  



 

9. COMPILING TERRAIN 

You need to compile and test the map for the first time, to verify that everything is working properly so 

far. This will only include surface map, elevation data, and a layers mask to define detail textures and 

clutter, and will include only a basic introduction to the most important features of Visitor 3. 

Visitor 3 reads XYZ elevation data (see XYZ Height field). 

1. Start Visitor 3: Start > All Programs > Bohemia Interactive > Tools > Visitor 3 

2. Start a new terrain with the XYZ. Choose Project > Open. Change the file type to XYZ then 

browse to your project's source folder to find the XYZ height map. 

3. It can take some time to process the file, and then a dialog will pop up and display information 

about the XYZ file. Ensure that the properties displayed exactly match your planning values. If 

they don't, something is wrong and you will have export a new XYZ height map with correct 

values. Click OK and a new terrain project will be started. 

4. Immediately save the project to  

P:\CA\tag_projectname\source\tag_projectname.pew 

NOTE: If you use the Save As command instead of just Save, you will need to manually type the PEW 

extension at the end of the filename or it will save a file without any extension. 

 

10. SETTING UP PROJECT PREFERENCES 

Project preferences tell Visitor where to store all the data it will create when it processes the satellite 

and mask image. It is critical to set this before importing any imagery. 

1. Tools > Project Preferences. There are three blank fields, and you only need to edit the first one, 

leaving the other two blank. 

2. Insert the path CA\tag_projectname\data in the first field. 

3. Save the PEW. 

 

11. SETTING UP PROJECT PARAMETERS 

The project parameters dialog controls the underlying construction of the map and must be set up 

correctly for each map project based on: 

• terrain size, 

• satellite texture size, 

• Terrain grid resolution. 

If you are setting parameters for a terrain that was imported from XYZ, the first section for terrain size 

will display the XYZ properties and will not allow you to change any values. 

1. Find the texture layer list in the bottom section, and look for the entry called Base (Active). 

Select it, then, click the Edit button and ensure that the texture size is 50m or the next lowest 

value. The options will always be multiples of your terrain the grid spacing, so if your terrain grid 

spacing is 8 m, your options will be 8, 16, 32, and 64. In this example, 32 fits the rule. 

2. In the middle section, click the Calculator button to open the satellite grid calculator. 

3. Enter your “satellite image” size in pixels into the first field. The other two values, Segment size 

and Segment overlap should both remain at 512 and 16 pixels respectively. 

4. You will see a calculated and proposed Satellite Grid value. Click Apply Proposed (nothing visible 

happens) and then Close. 

NOTE: The Satellite Grid value is now set correctly. 

5. Click OK to exit the Project Parameters dialog. 

6. Save the PEW. 

 

12. SURFACE MAP AND LAYER MASK 

Once your preferences and parameters are set, and the PEW is saved, you can import satellite and mask 

images for processing. Visitor 3 will use the Satellite Grid value you applied in the Project Parameters 

dialog to cut the large images into small tiles that conform to Direct X image size rules and will allow 

texture streaming. 

1. Go to Tools > Import Satellite + Mask… 



NOTE: Ensure that you start in the correct project's source subfolder. Browse back a few steps 

to ensure you are in the right project before selecting the layering file. 

2. Select the layers.cfg for your project and open it 

3. In rvmat selection dialog, check Text option (if you want to reserve *.rvmat files for editing) and 

click OK button 

4. In Select Satellite Map window, select  *.png file and open it 

5. In Select Layer Mask window, select  *.png file and open it 

NOTE: The import process can be very time consuming because of the huge amount of data 

being processed. Therefore tune your surface with small map first and If you are satisfied with 

the results, proceed with the large map. The progress bar might halt in some circumstances but 

allow it to continue working. You can monitor actual progress by looking into your project's 

data\Layers subfolder where Visitor 3 is storing all of the tiles that are being created. 

6. When the processing is done, the progress bar will disappear. 

7. Save the *.pew file. 

If you want to retexture your already existing map you need perform steps 2 to 7. 

 

13. PREVIEWING TERRAIN WITH REAL TIME VIEWER (BULDOZER) 

Once process has finished you can view the map in Buldozer. 

NOTE: When Buldozer is in focus, your mouse cursor will be inactive. Use Alt+Tab to switch between 

Buldozer and other open applications. 

1. Launch Buldozer from Visitor's menu, Project > Connect To Buldozer. 

2. When Buldozer starts, it will call other utilities that will convert any PNG images to Direct X 

compressed file formats, which are saved with a PAA file extension. 

NOTE: Depending on the size and resolution of your satellite data, this can take between 10 minutes 

and 3 hours. 

When all the processing is complete, the command prompt window will disappear and you will be able 

to see your terrain in Buldozer. 

The initial view in Buldozer will be displaying an area in the far northwest corner of your terrain, facing 

north. You might notice some badly matched or stretching satellite textures but this is normal since it is 

outside of the actual terrain area. To see your actual map area, rotate the camera in Buldozer with 

Numpad “4” or “6” and turn the camera around. In Visitor you can also click with the middle mouse 

button anywhere in the map to move the camera position in Buldozer. 

 

14. SURFACE REPRESENTATION 

The surface is represented by a pair of textures covering the whole map:  

• Surface Map (“Satellite Map”) 

• Layer Mask 

PNG format is used for both textures. Both textures are split into segments when imported to Visitor. 

Each layer mask segment is converted to 4 full colors during the process. Each segment overlaps its 

neighbors. 

The surface map provides the basic color information for displaying terrain on far range. As terrain can 

be visible beyond the range that objects are, representations of objects are all included on the surface 

map. 

The layer mask and layers defined in the configuration file determine surface textures to display at close 

range and other properties. 

The layer legend is accompanied with a configuration file, defining conversion from RGB to layers. 

Configuration file defines which color represents a layer. 

Examples for the layer mask segment and the corresponding surface map segment. Both segments are 

512 x 512 pixels in amount: 

  



 

Layer Mask Segment Surface Map Segment 

  
Layer mask is processed as an RGB image. Each pixel of the map image is interpreted as follows:  

• more matching color in the layer legend is found 

• based on nearest left and right basic surface the corresponding surface blend is used 

Editing cycle: (editing is usually done in Photoshop) 

1. Edit a surface map in Photoshop (sm_lco.png). 

NOTE: You need to use either a texture type _lco or _draftlco. 

2. Edit a layer mask in Photoshop (lm_lco.png). 

NOTE: You need to use either a texture type _lco or _draftlco. 

3. Tools > Import Satellite + Mask, 

4. Select layers.cfg 

5. Select sm_lco.png 

6. Select lm_lca.png 

7. Run Buldozer to check the result 

 

15. LAYERS LEGEND 

Visitor uses layerslegend.png as RGB reference for a layer mask. 

Example of a layer legend, it can be created using gradient in Photoshop. 

 
NOTE: Visitor uses the color spectrum of RGB reference. You can use names of the color fractions. 

NOTE: The same layer can be represented by multiple colors which blend the layers. 

  

480 х 480 480 х 480 16 16 



 

Example of the layer mask 

 
 

Example of surface map 

 
 

16. SURFACE MAP 

Surface map is a big texture mapped onto terrain as a group of overlapping segments. Their cutting and 

overlay is controlled by value of Satellite grid in the Project Parameters box. 

To prepare the surface map use a PNG picture of the same size which has been input for the Satellite 

Grid calculation. 

TIP: If you experiment with the surface map and you need to regenerate it often, you may use _draftlco 

suffix which causes the binarization to use faster but less accurate conversion of generated segments to 

PAA format. 

Delete _draftlco.paa content of Layers folder when you change suffix of source raster’s to _lco suffix. 

Each texture is represented: 

• At close range by a color only (_co) texture type and a normal map (_no**). 



• At middle range _mco texture type only. This is a greyscale texture that is multiplied with the 

surface map. 

 

17. LAYER MASK 

Size of the layers mask should be the same as the size of the surface map. 

TIP: It is optimal that you produce the layer mask using the surface map copy. You should follow the 

gradient depicted in layerslegend.png. 

The colors in layers mask should be discrete to avoid any artifacts on surface map. You need to use only 

4 colors on each single segment of the layers mask. It is because of the color conversion of the layers 

mask segments into 4 full RGB shades (black, red, green, blue). 

NOTE: It is better to first fit the layer mask with just 4 colors (black, red, green, and blue). After 

segmentation you can add other colors to each layer mask segment so as you will know where they are 

cut. You need to add colors so that within single segment will be up to 4 colors generally and the added 

colors are not like to these that already are on segment. 

For game engine use, each layer mask segment uses its own palette that is unrelated to the layer 

legend. 

Each layer within a surface map segment uses a color based upon the order in which the layers are 

defined in the configuration file. 

Colors are used in the following order:  

• Black (000000), 

• Red (FF0000), 

• Green (00FF00), 

• Blue (0000FF). 

This method of defining layers restricts each surface map segment to a maximum of four different layer 

types. All 4 layer types can be blended together within one pixel of the layer mask, Ground clutter 

appears to be placed based upon the dominant layer type. 

There are several RVMAT configurations for each segment, each defining a PixelShaderID. 

Each combination of layer types within each of the satellite grids within single segment requires its own 

RVMAT. 

 

18. SURFACE DEFINITIONS IN layers.cfg 

18.1 Representation of surface types by a layer mask 

Visitor during import of surface map and layer mask regenerates its own material definition for each 

segment it cuts and processes. It lists the detail textures to be used; the position is defined in the layer 

mask segment. The layer mask segment contains only discrete values of 4 basic RGB colors:  

• Red RGB 255,0,0  

• Green RGB 0,255,0  

• Blue RGB 0,0,255  

• Black RGB 0,0,0  

Composition of the layers within each of the layer mask segments may differ. If the layer mask should be 

edited as a whole then there must be more than these 4 basic RGB shades present on the surface map 

for representation of all the layers. 

Each material has its own RGB values, which are used in the layer mask. These RGB values must be set 

for every layer in layers.cfg, which is required for importing the surface map and the layer mask in 

Visitor. 

RGB values in layers.cfg must correspond to shades used in the layers mask. 

Class <texturename> defines a texture images and them own sets of the detailed textures. 

The configuration file describes the layer mask. It defines what layer legend is used, and it also defines 

materials for surface. 

  



 

//Textures 

class Layers  

{ 

  class sand 

  { 

    texture = "ca\<your_project>\data\sand_detail_co.png"; //the texture image 

    material="ca\<your_project>\data\sand.rvmat"; //the detailed textures 

  }; 

 

  class grass 

  { 

    texture = "ca\<your_project>\data\grass_detail_co.png"; 

    material="ca\<your_project>\data\grass.rvmat"; 

  }; 

 

  class city 

  { 

    texture = "ca\<your_project>\data\city_detail_co.png"; 

    material="ca\<your_project>\data\city.rvmat"; 

  }; 

 

  class bed 

  { 

    texture = "ca\<your_project>\data\bed_detail_co.png"; 

    material="ca\<your_project>\data\bed.rvmat"; 

  }; 

 

}; 

 

class Legend 

{ 

  picture ="ca\<your_project>\Source\ layerslegend.png"; 

  class Colors 

  { 

    //Colors must correspond to texture names 

    sand[]={{255,255,0}}; 

    grass[]={{0,255,0}}; 

    city[]={{0,0,255}}; 

    bed[]={{99,55,0}};  

  } 

}; 

 

18.2 Overlapping of the surface map and the layer mask segments 

The segments must overlap on their edges to avoid artifacts caused by texture filtering. This needs to 

share border on the edges, for example, 16-pixel. It is important to watch the extent and number of 

layers in segments, especially where there are more surfaces combined on area of few segments. You 

need to keep the extent of layers, which are not present on both adjacent segments, outside the shared 

borders in order to avoid strange interpretation of the layer mask during the segment generation. 

  



 

19. OBJECTS OF MAP EDITOR 

Inserting objects into the list - object template definitions 

You need insert the nature and artificial objects into the corresponding panel:  

Tools menu > Nature Objects /> Artificial Objects. Depending on the list in which model is inserted, it will 

be hidden or shown when particular filter is activated, and there is no other functionality in this 

classification. Objects (*.p3d) can be inserted into lists by clicking Add/Browse button. In Visitor objects 

exist as object templates defined by their template name, model, ranges of random orientation and size 

on insertion. 

In Nature / Artificial Objects Definition box, it is possible to change name, draw properties and size of 

randomization, pitch and facing of selected object. 

NOTE: Deleting object templates from list are possible only if those objects have deleted in the map. 

Navigation over map: 

• One-click MMB - point the cursor location. 

• Hold down RMB - pan a map. 

• Press Ctrl + J - get the cursor location. 

Inserting objects into the map: 

1. View > Panel of Objects 

2. In untitled box select the category of objects from drop-down list then select object 

3. One-click LMB on the map. 

Copying objects: 

1. One-click LMB on the object to select him 

2. Menu Edit > item Copy (Ctrl+C) 

3. One-click MMB to place the editor cursor on a map where you want place the copied object 

4. Select Edit > Paste (Ctrl+V) 

NOTE: You can copy objects to target project from a source project: 

1. Open a target project 

2. Go to Project > Import Templates… 

3. In box Open, browse to a *.pew file of the source project, and open it. All the object definitions 

of the source project will have entered into the corresponding lists of the target project. 

4. Go to Project > Open… 

5. In box Open, browse to the *.pew file of the source project, you just imported templates from, 

and open it. 

6. In the work window of the source project, select objects placed on the map, you want 

7. Select Edit > Copy (Ctrl+C) 

8. Go back to target project: Project > Open… 

9. In box Open, browse to a *.pew file of the target project, and open it. 

10. One-click MMB to place the editor cursor on a map where you want to place the copied object. 

11. Select Edit > Paste Relative (Ctrl+V) 

NOTE: If you copy objects from such a map what is in the target project, and want  that they will 

place at the same location, then you need to select Edit > Paste Absolute (Shift+V). 

 

Editing objects and areas on the map: 

1. One-click LMB on an object/ area - select object/area 

TIP: If you place mouse cursor over object and press O key, object will be highlighted and 

selected in panel of objects. 

2. Hold down LMB while move the mouse over objects/areas - select objects/areas 

3. Hold down Ctrl + one-click LMB on an object/area - including object/area to selection 

4. Hold down Shift + one-click LMB on an object/area - excluding object/area from selection 

NOTE: You can deselect all the objects by one-click LMB on a map 

5. One-click LMB on an object to select it then hold down LMB on this object and drag the mouse – 

move an object 

6. Double-click LMB on an object - open Object properties dialog. You can do the same by one-click 

LMB on an object to select it then press Enter key. 



 
 

Deleting objects on the map: 

4. One-click LMB an object on the map 

5. Press Delete key 

Alternative way to delete object: 

• Start Buldozer 

• Hover editing cursor (the white box) on the object. 

• One-click LMB on this object, the selection arrow (the vertical white arrow) will appear over 

object. 

• Press Alt+Tab keys to switch from Buldozer to Visitor. 

• Press Delete key 

 

Named selections 

When objects are selected, it is possible to name this selection. 

• Select objects 

• View > Named Selections Panel 

• One-click RMB in list of selections – open context menu. 

 

Creating roads 

1. Tools > Roads... item 

2. Click Add... button 

3. On tab Road, name a road 

4. On tab Straight Parts 

5. On tab Curves 

6. On tab Special Parts 

7. On tab Terminators 

 



Then go through all the categories like "Straight parts", "Curves", etc. and add new road parts. Once a 

category is selected, click on "Browse…", navigate to "P:\ca\roads2" and select asf1_6.  

Road extensions  

Straight parts Curves Ends 

• _6 

• _12 

• _25 

• _10 25 

• _10 50 

• _10 75 

• _10 100 

_konec 

1. Select Road networks from the panel of objects 

2. One-click on the map 

• Type of key part - step 1: Select Straight part of > Next 

• Key part - step 2: Select key part > Next 

• Parameters of key part - step 3: Key part > Next 

• Create key point - step 4: Press Finish 

3. Start building your road 

Buldozer has the habit of crashing if new content is added to the Panel of Objects, so make sure to set 

up all the objects you want to use before starting Buldozer on big island projects where loading the 

terrain in Buldozer takes 5-10 minutes.  

Now add some stuff like roads, buildings, bushes to the terrain. Use Buldozer to fine-tune.  

 

20. EDITING IN BULDOZER 

Buldozer is a real time viewer which connects with Visitor to give you a 3D render of your terrain area. 

This is really just the rendering engine operating without any simulation. 

 

20.1 Setup Customization 

You can customize bulldozer.exe: 

1. Run Visitor 

2. Tools > System Preferences to set the path to the real time viewer (Buldozer) in working 

directory (standard is P:\). All path indications will be relative to this path. 

NOTE: If something does not work as expected you should check there first. 

3. Define the call parameters for Buldozer: 

“P:\bulldozer.exe” [-window] –buldozer [-cfg=PathToConfig] -addons=ArmaAddons.txt 

NOTE: Commands in squad brackets [] are optional. Leave [] away when using these commands. 

 

Parameters: 

-window – the parameter starts Buldozer in window instead of full screen mode. 

-cfg=PathToConfig – the parameter forces Buldozer to use a certain configuration file. 

For example: C:\Documents and Settings\<user_name>\My Documents\ArmA2\ArmA2OA.cfg 

By default Buldozer uses Buldozer.cfg located there, but you may as well use your own 

configuration file located wherever you fancy. 

-addons=ArmaAddons.txt – the file containing list of add-ons which are used when 

arma2oa.exe runs in Buldozer mode. Particularly useful for UI elements required for your work 

in Buldozer (the arrow marker, the box cursor), as well as for other unnecessary things like skies 

or clutter. Content of *.txt file is referring to unpacked data on your working disc (P:\), not to 

PBOs in game installation. ArmaAddons.txt must be located on the root of disk P. It is a list of 

add-ons, configurations of the listed add-ons will be used. E.g. if you want to see correct clutter 

settings for edited world, its folder must be mentioned in p:\ArmaAddons.txt. 

Example of file ArmaAddons.txt with paths to addons 

addons[] = 

{ 

  "ca\", "ca\data\", "ca\UI\", "ca\UIFonts\" 

}; 

NOTE: the path must end with backslash \, otherwise it will be considered as file, not path. 



-connect=pipe\<AnyNameYouLike> - the use named pipe and specify its name. 

NOTE: Useful especially when debugging. Not required for end-users. 

-maxmem=1024 – the parameter defines amount of memory that can be used by the viewer. 

Typical setup of real time viewer parameters 

 
 

d:\%armapath%\ your_armagame.exe -buldozer -window -addons=ofp2addons.txt -maxmem=1024  

-connect - It is possible not to specify the viewer *.exe. This tells Visitor it should only create the 

pipe and listen to any incoming connections on it. 

-connect=pipe\Visitor 

This is handy when launching the viewer externally. Options other than -connect are ignored when used 

this way. 

 

20.2 Buldozer Customization 

You can customize the controls of Buldozer: 

• by pressing F1 in Buldozer  

• by browsing Controls > Buldozer in Arma2 OA. 

NOTE: You might get some errors if your content is not unpacked correctly. 

 

20.3 Camera Control 

To connect Buldozer select Project > Connect to Buldozer (CTRL + F7) or click red exclamation ( ) 

button. 

NOTE: When Buldozer is started for the first time or you change any textures (regenerating surface 

(“satellite”) segments, altering objects textures), it will convert PNG / TGA to PAA format, which may 

take a while. If application does not respond, let it finish its job, do not terminate it. 

To disconnect Bulldozer press Alt+F4 keys. 

TIP: To switch between Visitor and Buldozer press Alt+Tab keys. 

  



 

keyboard mouse description 

Q/PgUp  Upward move 

Z/PgDn  Downward move 

NOTE: You can increase the speed of action by pressing the Shift together with the above these. 

Numpad 8  Upward rotate 

Numpad 2  Downward rotate 

Numpad 4  Left rotate 

Numpad 6  Right rotate 

Numpad “+”  Zoom In Relative To Box Cursor 

Numpad “-“  Zoom Out Relative To Box Cursor 

 move mouse Pan 

Shift + move mouse Quick Pan 

 

20.2 Terrain Editing 

• Press S - switch between object and terrain edit modes 

• Press H key - turn on/off the arrow marker for marking of a terrain vertex nearest to the editor 

cursor. 

• Press U/I - Raise a terrain vertex by 1 meter/5 meters. 

• Press J/K - Lower a terrain vertex by 1 meter/5 meters. 

 

20.3 Objects Editing 

• Press S - switch between object and terrain edit modes 

• Place the box cursor over an object then one-click LMB– select object. 

NOTE: If you select objects in Buldozer then they are selected in Visitor and vice versa. 

• Place the box cursor over an object and one-click LMB to select it then hold down RMB while 

mouse is moved - rotate object. 

NOTE: Origin of rotation is defined by the position of the box cursor. 

• Place the box cursor over an object and hold down Ctrl + one-click LMB on an object/area - 

including object/area to selection 

• Place the box cursor over an object and hold down Shift + one-click LMB on an object/area - 

excluding object/area from selection 

NOTE: You can deselect all the objects by one-click LMB on an empty place of a map 

• Hold down LMB on selected objects and move the mouse sideways - move selected objects. 

• Hold down RMB on selected objects and move the mouse sideways - rotate selected objects. 

NOTE: Origin of rotation is defined by the position of the box cursor. 

• Hold down LMB on selected objects and press Q key - move selected objects upward. 

• Hold down LMB on selected objects and press Z key (Y key for European layout) - move selected 

objects downward. 

NOTE: Press N to turn on/off FLIR filter. Thus, you can get an object view at day or night. 

 

20.4 Editing with Visitor3 and Buldozer 

While much can be done with shape files, sometimes it is necessary to edit specific areas by hand. This is 

easily done with Visitor3 in combination with Buldozer. The 2D view in Visitor and the 3D view in 

Buldozer are synchronized so any changes made in one view will be transmitted to the other view. 

Buldozer is the 3D viewer that will enable you to view the terrain in real time. 

To activate it, select Project > Connect to Buldozer. 

Buldozer is really just the game engine, so your windows mouse cursor will disappear when the Buldozer 

window is in focus. 

To restore focus to other windows in your taskbar, use Alt+Tab. 

To close Buldozer, use Alt+F4. 

When Buldozer first loads, it will be displaying an area in the far North West corner of your terrain, 

facing north. You might notice some badly matched or stretching satellite textures but this is normal 



since it is outside of the actual terrain area. To see your actual map area, rotate the camera in Buldozer 

with Numpad “4” or “6” and turn the camera around. 

 

21. VISITOR3 OBJECTS DATABASE 

Each Visitor3 project uses a database of objects. These objects are local to the project, but each object 

must be associated with a unique P3D model. The visitor object stores additional information for 

displaying in Visitor's 2D map such as icon style, and it also include placement randomization values 

which are used when you place the object manually in Visitor3. The database is divided into three 

categories, but this is only for organization within the Visitor3 workspace, these categories have no 

impact on simulation within VBS2. 

 

Objects Database: Manual Entry 

To add new objects to the database, click Tools and then select the best category for the type of objects 

you want to include: Nature Objects, Artificial Objects or Road Objects. The object definition dialog will 

open and you can use the Add/Browse... button to create new object by selecting P3D models from the 

P: drive. You can edit the appearance of the objects here (colour, shape, border color) and also the 

randomization properties. 

 

Objects Database: Import From Other Project 

A shortcut for setting up a new objects database is to import it from an existing PEW file that already 

has a database setup the way you want it. Use Project > Import Templates... and browse to another 

PEW file. The database from the target PEW will be imported to your current project. 

 

22. MAP CONFIGURATION 

You have to design and create a configuration file (config.cpp) for your terrain. It guides you through 

each section and helps you enter the correct information. 

Enter a display name for your terrain that users will see in editor menu. 

In the Global Position section, enter UTM values for your terrain's north, south, and west extents. These 

values are embedded into the map correlation and also to set correct values for the grid shown in the 

2D map view. 

Enter the Geographic Coordinates for the south west corner in decimal degrees (ddd.dddddd) rather 

than degrees minutes, seconds (dd mm ss.sss). This is used for simulation of star maps, and sun position 

based on the current date and your position on the Earth's surface. It doesn't need to be very accurate. 

In the Surfaces section, you can define up to 4 surface types for your terrain. 

Give your surface a simple name with no spaces or special characters such as: grass, desert, swamp, etc. 

Choose mask colors that will be used to represent this surface type when you create you’re the layer 

mask. 

NOTE: Each surface needs a unique color. 

 

Select a base surface to inherit from. Choose the most sensible description. 

• A surface for grass should inherit from <tag>_land_grass_low or <tag>_land_grass_high. 

• A surface for desert should inherit from <tag>_land_sand_*  

• A surface for swamp could inherit from <tag>_land_mud or <tag>_water_shallow. 

You have an option to add clutter objects to each surface that you create. Add the clutter models that 

you think will be appropriate for this surface; it is easy to edit the clutter characteristics later. 

Repeat steps for each surface that you want to define on your terrain. When you have completed 

creating surfaces, click the save button to write a tag_projectname\source\config.cpp. You can edit this 

file later to make changes. 

This has been created: tag_projectname\config.cpp 

  



 

23. EXPORTING PEW TO WRP 

WRP files are optimized terrain areas that are formatted for ArmA 2 series. 

To export PEW to WRP: 

1. Ensure that Buldozer is running and your terrain is visible in the viewer 

NOTE: Some map data is handled by Buldozer, so when exporting a map project to WRP format, 

Buldozer must be running and displaying the terrain. 

2. Project > Export World… and browse to the root of your project folder. 

NOTE: This file must be named the same as the project folder: 

tag_project.wrp 

3. Once the export is complete, you can close Buldozer and Visitor. 

 

WRP file contains the map itself. It is generated by Buldozer along with HPP file. 

HPP file is included into Names class of the map's parameters config.cpp file using #include 

operator. It defines map names and appearance of 2D map symbols in game. Key points tool of 

Visitor is used to insert those data. 

 

24. EXPORTING OF PROJECT LAYOUT 

Best way to get the data about placement of objects on terrain is export an image of a map. To improve 

visualization of objects you can do following. 

Terrain 

1. View > Define configuration... CTRL+F 

2. In tab Colors - height 

• Set Minimal/Maximal ground height to gradient from white to 50% gray. 

• Set Color of contours to some less distinct shade. 

• Set Elevation interval style so that waterline could be used as reference for painting 

beaches. It is better to entirely switch off contours or select broader interval of 10-50m. 

3. Turn off features of drawing that are not needed, e.g. grid. 

 

Objects 

When selecting forest surface based on vegetation, for artificial shadows of trees or painting of roads, 

you can use symbols of objects in Visitor. For better selection of objects in Photoshop, it is useful to 

have same color for object border and its body: 

• Tools > Nature objects... – the option allow adjust colors of natural objects in project. You may 

either choose the same color for all or use different colors for broadleaf and coniferous species. 

You may also use ellipse instead of rectangle symbol. 

• Tools > Roads... - the option allow change color of road types. 

• Tools > Artificial objects... - the option allow adjust colors of artificial objects in project. You can 

use of position of artificial objects, especially when painting surfaces in cities. Some objects can 

be selected (e.g. using script) and added to selection. This allows hiding of object groups 

regardless of their type. 

 

24.1 Export Map As Image 

1. Project > Export Map as image...  

2. Choose EMF file type by default. 

NOTE: It is impossible to export image in big resolution as BMP file type. 

Resolution should be the same as Terrain size plus the size of blue edge (TM)', visible on left and 

bottom side of the map in Visitor. 

Later the blue edge will be cut out; it needs to add because output of whole map in same resolution as 

texture is needed. 

Width of blue edge (TM) is the size of a terrain cell in pixels of surface map. 

To learn this, you can do following: 

Image size / Terrain grid size = Terrain cell size in pixels 

 



24.2 Pre-processing of image exported for map 

You need convert EMF to PNG file type. In the Visitor folder, there is utility EmfToPng.exe for this job: 

1. Copy this utility into folder containing your *.emf file. 

2. Select the *.emf file then drag-and-drop it on EmfToPng.exe 

NOTE: You can open created PNG size up to 40960x40960px in Photoshop CS and higher. 

The PNG image exported would not match your surface map by size. You need to cut the blue edge from 

left and bottom edge of the image. 

 

25. PACKING A MAP 

To pack the map into PBO file, you need to have: 

1. config.cpp (+HPP), 

2. WRP file, 

3. Textures in PAA format 

4. All the relevant RVMAT files. 

If you use your custom objects in the map, you should pack them and add them to: 

%ArmA2 directory%\@tag_addonname\Addons\<your_project> folder. 

NOTE: Structures described here reflects working customs of BI. Public utility used to pack PBO files 

packs all the content of a designated add-on folder (in this case the <your_project> folder), therefore it 

is wise to keep clean "packing" version separated and keep there only needed files. 

TIP: If you cannot see your map in map list, game crashes after you attempt to preview mission on your 

terrain or you cannot see surface textures, check all paths in config.cpp and *.rvmat files in Data folder. 

Also make sure that any referenced files exist at the specified location. 

 

26. CREATING A ARMA 2 ADD-ON 

You need to package the map into ArmA 2 -ready format. This will store the configuration file, the 

terrain WRP, and all of its imagery into a single PBO file, similar to a zip archive. 

1. Launch the PBO Packing Utility from Start > All Programs > Bohemia Interactive > Tools > PBO 

packer. 

2. Click the Browse button and select your project folder. The PBO will be created with the same 

filename as the project folder. For example, if you have a terrain in bia_kettlevalley20km then 

PBO packer will produce a bia_kettlevalley20km.pbo add-on. 

3. Leave the packing options at default (these are explained later), and then click the Pack button. 

NOTE: Once again, this can be a lengthy process depending on the size of your “satellite image”. 

Progress information is written into the console and it will report when packing is complete. 

The PBO packer has two options which you may sometimes need to use. 

The first option, Force Rebin purges the temp folder. Normally converted data is stored in a temporary 

location so the first time you pack a map might take two hours, but if you pack again without making 

any changes, it should take less than 5 minutes. This is convenient if you are only making small config 

changes, you have no need to repack all of the satellite imagery again, only changed files are converted 

again. This is very rarely used. 

 

27. TESTING A TERRAIN IN GAME 

Once the PBO packer has created an add-on (PBO file type) it can be found at P:\export. To test it you 

need to move this file into your ArmA 2 installation. The default add-on folder location is: 

C:\Program Files\Bohemia Interactive\ArmA 2\AddOns 

Before placing your add-on here, shut down ArmA 2 if it is running. When you restart ArmA 2 it will 

automatically find the new add-on and include it into the available content. When a new terrain area 

has been added, it will be available in the list of terrains for the mission editor. 

1. Exit ArmA 2 if it is currently running. 

2. Find your new terrain add-on in P:\export 

3. Copy the add-on PBO file to your ArmA 2 installation's ArmA 2\ AddOns. 

4. Restart ArmA 2. 

5. From the Main menu press Alt+E (Ctrl+E). 

6. Find your new terrain area in the list of available maps, select it and click Continue. 



7. In the mission editor, select Edit in 3D world 

8. Control the editor camera using WASD direction keys, Q and Z for altitude, and right mouse 

button, you can move around your whole terrain area and inspect textures and elevation to see 

if you are happy with the general look. 

 

Release: 03.29.2014 

Publisher: http://vied-arma.ucoz.com/ 


