
Master 

Visitor 3 Personal Edition 

(BI Tools v2.5.1) 

The manual assumes that you have to run the terrain V3 Visitor 3 Personal Edition. 

TIP: To access the V3 while reading this manual, switch these by the pressing the left Alt+Tab keys. 

NOTE: The abbreviations used here: 

• LMB (Left Mouse Button) 

• MMB (Middle Mouse Button/Scroll Wheel) 

• RMB (Right Mouse Button) 
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INTRODUCTION 

The terrain V3 is delivered by Bohemia Interactive a.s. with the package versions: 

Package Versions BI Titles 

BI Tools ArmA 1 (Armed Assault) 

BI Tools 2 and BI Tools 2.5 ArmA 1, ArmA 2 

BI Tools 2.5.1 ArmA 1, ArmA 2&Operation Arrowhead 

 

1. INTERFACE 

Main toolbar 

 
TIP: To get better idea on a terrain, turn on the Show shadows button. 

 

 
  



 

2. TOOLS 

2.1 Natural Objects 

The Natural objects button on the top toolbar is used to show the objects on a map. 

To access the objects definition, select Tools > Natural Objects 

Options of the Natural Objects Definition: 

• Add/Browse… - add and browse the objects (*.p3d files). 

NOTE: The maximum length of the object name has to be up to 50 characters. 

• Randomize Object: 

o Randomize size interval – a random size of a model. 

o Randomize angle interval – a random angle of a model. 

o Randomize orientation interval – a random facing of a model. 

NOTE: Randomization can be realized with a script. 

 

2.2 Artificial Objects 

The Artificial objects button on the top toolbar is used to show the objects on a map. 

To access the artificial objects definition, select Tools > Artificial Objects 

Options of the Artificial Objects Definition: 

• Add/Browse… - add and browse the objects (*.p3d files). 

NOTE: The maximum length of the object name has to be up to 50 characters. 

• Randomize object: 

o Randomize size interval – a random size of a model. 

o Randomize angle interval – a random angle of a model. 

o Randomize orientation interval – a random facing of a model. 

NOTE: Randomization can be realized with a script. 

 

2.3 Roads 

The road types are defined here. 

NOTE: The Crossroads are the road parts that need to have suitable the road types defined for each of 

their ending directions. 

To define a Road type: 

1. In the V3 window, select Tools > Roads… 

2. In a untitled dialog box, one-click LMB the Add… button 

3. In next untitled window, input a road settings: 

• Road –define main settings of a road type. 

• Straight Parts–define the straight parts of a road. 

NOTE: These parts have certain length, for example: 6.25, 12.5 or 25 meters. 

• Curves –define the curved parts of a road. 

NOTE: These parts have a certain radius, for example: 25, 50, 75 or 100 meters. 

• Special Parts –define the special parts like a T-shape and X-shape of a road. 

• Terminators–define the end parts of the road. 

NOTE: These parts are suffixed by “_konec”. 

4. One-click LMB on the OK button to close the window with road settings. 

5. One-click LMB on the OK button to close the window with defined Roads and Crossroads. 

NOTE: A name of a road type will appear within the Road networks list in the Panel of Objects tool box. 

  



 

2.4 Forests 

(for Operation Flashpoint (OFP) only) 

The forest contents are defined here. 

To define a forest type: 

1. In the V3 window, select Tools > Forests 

2. In Forests dialog box, one-click LMB the Add… button 

Forest definition dialog: 

• Forest parameters section: 

o Name (type) of - self-explanatory 

o Outline: standard/special checks – these define a color of the forest outline 

o Color: standard/special checks – these define a color of the forest objects 

• Forest objects section: 

o Square-fill: – this defines the forest objects within the square zone. 

o Square-:– this defines the forest objects on borders of the square zone. 

o Triangle (+ - it is unknown. 

3. One-click LMB OK button to close the Forest definition dialog box. 

4. One-click LMB OK button to close the Forests dialog box. 

A name of a forest type will appear within Woods (OFP) list in Panel of Objects tool box. 

NOTE: The number of forest types used affects performance (especially the workload of the CPU). 

 

2.5 Project Parameters 

The project parameters contain basic information about the project size. The most of settings is 

available when project is started. After the project has been set, the Satellite Grid, Texture layers and 

Satellite grid calculator settings are only available. 

 

2.6 Project Preferences 

The project preferences define a path to textures, objects, and other settings: 

• Folder – Textures field defines a path to the terrain textures. 

• Folder - Objects field defines a path to the terrain objects. 

NOTE: All the paths are relative in the terrain project. Thus, you have to keep the project structure. 

 

2.7 Object Manager 

There are only two functions. 

NOTE: The Buldozer has to be disconnected with the V3 when using these functions. 

If the Resolution LOD size or Geometry LOD size of a model is changed, then these functions are useful 

to update object description or to fix object shifts in vertical axis, including recalculation of the objects 

to relative elevation to surface = 0. 

 

2.8 Replace Objects 

The option allows deleting and replacing the instances of a given object from the terrain. 

 

3. EDITING MODES 

3.1 Artificial Objects 

To create an artificial object: 

1. In the V3 window, select View > Panel of Objects item. 

2. In the untitled drop-down menu, select Artificial objects (F1 key) item. 

3. Select an artificial object. 

4. One-click LMB on the map where you want to place it. 

NOTE: The list contains artificial objects except the road types. 

  



 

3.2 Natural Objects 

To create a natural object: 

1. In the V3 window, select View > Panel of Objects item. 

2. In the untitled drop-down menu, select Natural objects (F2 key) item. 

3. Select an natural object. 

4. One-click LMB on the map where you want to place it. 

NOTE: The list contains natural objects except the forest types. 

TIP: It is recommended to use World Tools instead of this method. 

(See the World Tools: Creating Vegetation TAGorial) 

 

3.3 Road Networks 

To create a key part of road: 

1. In the V3 window, select View > Panel of Objects 

2. In the untitled drop-down menu, select Road networks (F3 key) 

3. In field below, select a road type you want 

4. One-click LMB on the map where you want to place it 

5. In the Type of key part {1. from 4} window: 

1) Select a type of a key part, and one-click LMB on Next button 

2) Select a key part of a road, and one-click LMB on Next button 

3) Set up parameters of a key part, and one-click LMB on Next button 

4) Create a key point of a road, and one-click LMB on OK button 

NOTE: 

• To use this editing mode, take the unbinarized format (MLOD) of *.p3d files supplied with BI 

Tools in the default directory P:\CA\Roads2. The binarized format (ODOL) of *.p3d files 

supplied with a game in the directory %game_installation%\Addons\Roads2.pbo is not 

suitable for. In a text editor, the unbinarized files start with letters MLOD, but the binarized 

ones start with letters ODOL. 

• To see the road parts, click the Show roads button on the view toolbar. 

 

To edit a road double-click LMB on a road. 

Settings of “Key part of road”: 

• Orientation of key part (direction A) - Direction the A end is facing. 

NOTE: The angles are only possible in 10° per step. 

• Position X and Z - Position of the key part on the map. 

• Modify Dir. A/B – create/delete parts of a road in the A/B direction. 

• Gen.Terminator - create Terminator or new key part at the end of certain direction. 

• All Parts Of This Direction - all parts from the key part to the end of the road. 

NOTE: 

o Adding or deleting a part in the middle of the road changes also the rest of the road. 

o Added part will be inserted before the part selected in All parts of this direction list. 

• Delete - delete a selected road part 

• Straight Part - add the selected straight part to the road. 

• Left Curve - add the selected left curve part to the road. 

• Right Curve - add the selected right curve part to the road. 

• Special - add the selected special part to the road. 

 

3.4 Key Points 

To create key points: 

1. In the V3 window, select View > Panel of Objects. 

2. In the untitled drop-down menu, select Key points (F4 key). 

3. One-click LMB on the map where you want to place it. 

NOTE: The same options as in Named Zones editing mode (see below). 

 



3.5 Terrain Vertices 

To access terrain vertices: 

1. In the V3 window, select View > Panel of Objects 

2. In the untitled drop-down menu, select Terrain vertices (F5 key) 

3. One-click LMB or draw a selection box on the map where you want to edit a location 

Change height… 

 
 

• Change only – this is active when the selection contains sea points and land points. 

o ground (positive height) - vertices above water level can be only changed. 

o sea (negative height) - vertices below water level can be only changed. 

• Minimal Height - vertices will set to the lowest level in a selection. 

• Median Height - vertices will set to the median level in a selection. 

• Maximal Height - vertices will set to the highest level in a selection. 

• Average Height - vertices will set to the average level in a selection. 

• Height - vertices will set to the custom height. 

• Transform into interval - take the current height profile in a selection and stretch it into the 

given height interval. 

 

Erosion: 

• nGens – a number of generations of erosion. 

• washCoef – a coefficient about how strong does water flow affect terrain. 

• sedimCoef – a sediment coefficient about how fast sediments sink down and stay. 

• sedimBase – a sediment base about how much sediment is there from the beginning. 

• sedimEff – a sediment effect, "wash out" resistance of terrain. 

• initRain – strength of rain. 

• steadyRain - How long does the rain last. 

• finalBlur - a surface smoothing. 

 

3.6 Background Image 

To set background image: 

1. In the V3 window, select View > Panel of Objects. 

2. In the untitled drop-down menu, select Background images (F6 key). 

3. Click LMB on the New image button. 

4. In the Create background image dialog box, choose *.bmp file. 

NOTE: A BMP image format is only supported. 

5. Set coordinates X and Y for top left corner of the background image 

NOTE: For the image covering whole map, set both the X and Y to the value of 0. 



6. Set Width and Height of the image. For example, if the map has 10240x10240 meters and the 

image covers whole map, set Width and Height sizes to 10240. 

NOTE: You can use the several parts of the image together to cover the background, correctly 

setting the coordinates and sizes. 

 
 

3.7 Named Zones 

To access named zones: 

1. In the V3 window, select View > Panel of Objects. 

2. In the untitled drop-down menu, select Named zones (F7 key). 

3. Draw a selection box. 

NOTE: To name a zone one-click LMB on the selection. 

Options: 

• Go To... - center the view on a selected zone. 

• Properties – open window (double-click LMB on the selection). 

• Select area under zone – select area that is within the zone. 

• Select objects in zone - select objects that are within the zone. 

 

3.8 Named Objects 

To access named objects: 

1. In the V3 window, select View > Panel of Objects. 

2. In the untitled drop-down menu, select Named objects (F8 key). 

Option: 

• Go To... - center the view on selected object. 

 

3.9 Surfaces (OFP) 

(for Operation Flashpoint only) 

To access surfaces: 

1. In the V3 window, select View > Panel of Objects. 

2. In the untitled drop-down menu, select Surfaces (OFP) (F9 key). 

3. Draw a selection box. 

Options: 

• Terrain type – the type of the selected area. 

• Surfaces - selected surface. 

• Textures - selected texture. 

NOTE: If set to "random selection" it will randomly choose one of the available textures. 

• Set texture onto area - set the selected texture on selected area. 

NOTE: The textures are set according to their probabilities and their definition. 

• Set surface onto area - set the selected surface on selected area. 

NOTE: The surfaces are set according to their definition. 

• Set terrain onto area - set the selected terrain on selected area. 

• Change texture onto area - change the current texture in area with the selected texture. 

• Texture Analysis… 

  



 

3.10 Woods (OFP) 

(for Operation Flashpoint only) 

 

To create/edit woods: 

1. In the V3 window, select View > Panel of Objects. 

2. In the untitled drop-down menu, select Woods (OFP) (F10 key). 

3. Drag a selection box on a map where you want place forest. 

4. One-click LMB on the Area forestation button. 

5. In Create forest dialog, set up following: 

• Control parameters of forest section: 

o Type of forest: - this defines a name of a forest type. 

o “Smooth” convex angles check box – self-explanatory. 

o “Smooth” concave angles check box – self-explanatory. 

o Generate parts with bushes around forest – self-explanatory. 

o Cancel selected area after forest creation – self-explanatory. 

6. Click OK button. 

NOTE: This tool for a creating of forests is obsolete and kept only for backwards compatibility in maps 

for Operation Flashpoint. 

 

4. SCRIPTS 

The V3 can use the script files *.vis (see the Visitor Script Command Reference). 

 

5. PROJECT STRUCTURE 

Naming Convention 

The naming convention of the project matches to tag_projectname: 

• The “tag” presents to an author. 

• The “project name” presents a project. 

NOTE: The name should have no spaces or special characters. 

 

Project Structure 

The default CA tag means the BI Studio contents. Thus, the P:\CA directory has to keep these. You can 

keep your contents separately from the BI Studio contents and the other ones on the virtual P: drive. 

1. Create the work directories: 

P:\<tag>\<tag_projectname> 

• \Data 

• \Source 

o \export 

� \images 

� \terrain 

o \import 

� \images 

� \terrain 

2. Place the texture data into directory \<tag_projectname>\Data: 

• <texturename>_detail_co.png - the layer textures 

• <texturename>_detail_nopx.png - the normal maps for the layer textures 

• <texturename>.rvmat – the engine materials for the layer textures 

• ui_select_<terrainname>_ca.png - the image for the project presentation 

NOTE: When Bulldozer is first start, it creates the directory \Data\Layers. 

The Layers folder contains: 

• The segments of the map texture (Satellite Map) 

• The segments of the layer mask 

• The *.rvmat files for each segment of the map texture 



3. Place your image data into directory \import\images: 

• layerlegend.png - the reference colour file. 

• sm_<mapname>_lco.png - the map texture (Satellite Map). 

NOTE: The Satellite Map is a term that refers to both the actual satellite image of the Earth's 

surface and the other image like it. 

• lm_<mapname>_lca.png - the layers mask; 

• layers.cfg - the configuration file of the layer textures 

4. Place a height map data, such as *.xyz and etc., into the directory \import\terrain. 

 

Setup Stuff 

You need stuff such as buildings, plants and etc. in directory P:\CA in order to work with. 

If you will use stuff from your game, do following: 

1. Download ExtractPbo and DePbo by Mikero from here. 

NOTE: There are other tools to extract PBO and unrap config.bin. 

2. Extract the ExtractPbo where you want to be placed it. 

3. Copy the DePbo.dll, following instructions in readme.DePbo.txt. 

4. Extract the addon Ca.pbo, and also other ones, you need, from the directory 

%game_installation%\Addons. 

5. Copy the contents of the Ca addon extracted into the directory P:\CA. 

6. Copy the other addons extracted into the directory P:\CA. 

7. Create another folder P:\<tag>\CA. 

8. Open the MS Notepad. 

9. In the Notepad window, enter the command: xcopy *.cpp P:\<tag>\CA\ /S /Y 

10. Save the file as copy_configs.bat into the P:\CA. 

11. In the Notepad window, change the command: xcopy *.hpp P:\<tag>\CA\ /S /Y 

12. Save the file as copy_headers.bat into the P:\CA. 

13. Close the MS Notepad. 

14. Open the copy_configs.bat file. Wait until it is done. 

15. Open the copy_headers.bat file. Wait until it is done. 

NOTE: You have to keep your contents with some CA ones together in single scope to access them. The 

structured CA data copied will be used by the BinPBO utility when your project is packed. 

 

6. PROJECT SETUP 

Setting up a terrain project: 

1. In the V3 window, select Project > New (CTRL + N) 

2. In the Project parameters dialog box, set the following: 

• Terrain grid size (in vertices). 

• Terrain cell size (meters) - distance between the vertices in X and Y axis. 

• Terrain size (meters) = Terrain grid size x Terrain cell size, calculated automatically. 

Click LMB on the Calculator button. 

• In the Satellite grid calculator dialog box, set the following parameters: 

o Image size (pixels) - a size of the map texture (Satellite Map). 

o Image resolution (meters/pixels) = Terrain size / Image size. 

o Segment size (pixels) 

o Segment size (meters) = Segment size x Image resolution. 

o Segment overlap (pixels) 

o Segment overlap (meters) = Segment overlap x Image resolution. 

o Calculated (in cells) = (Segment size - Segment overlap) / Terrain cell size. 

o Proposed: (the rounded quantity of the cells) 

o Segment overlap (proposed): 

3. Click on the Apply proposed button 

4. Click on the Close button. 

5. In the Texture layers section set the area in which the layer textures are mapped. 



  
(See Making Satellite Texture and Mask chapter) 

 

6. Select Tools > Project Preferences. 

 
The Folder - Textures field points a directory where following generated and stored by V3: 

• Segments of a map texture (Satellite Map) 

• Segments of a layer mask 

• The *.rvmat files for each segment of the map texture (for ArmA 2 series) 

The Folder-objects field points a directory where the objects are stored, P:\ by default. 

7. Click on the OK button. 

NOTE: These settings provide the import the map texture (Satellite Map) and the layer mask. 

NOTE: Layers may be generated into another folder and packed into separate PBO file. 

8. Select Project > Save as 

9. In the dialog box, save the file <project_name>.pew into P:\CA\<project_name>\Source. 

 

6.1 Terrain Grid and Terrain Size 

Operation Flashpoint Series 

NOTE: By default, for ArmA Cold War Assault (Operation Flashpoint) the terrain resolutions are: 

• 50x50 meters – a value with least lag of a game engine, in meters 

• 25x25 – a default value for a multiplayer mode, in meters 

• 12.5x12.5 – a default value for a singleplayer mode, in meters 

• 6.25x6.25 - a value with more lag of a game engine, in meters 

• 3.125x3.125 - a value with most lag of a game engine, in meters 

  



 

If unsupported cell size was selected, then nearest supported value is used instead. 

NOTE: The setTerrainGrid scripting command introduced in Operation Flashpoint: Resistance v. 1.75. 

This sets the terrain resolution (in meters): more value means less the vertices for terrain rendering. 

The value of 12.5 corresponds to Terrain Detail: Normal in the Video options. 

For ArmA series the terrain resolution is fixed and is determined by the terrain project. Thus, the 

setTerrainGrid scripting command sets the terrain LOD. 

Parameters that determine your terrain: 

• Terrain grid size 

• Terrain cell size 

• Terrain size 

• Satellite Image Resolution 

• Satellite Image Size 

You can define the first three parameters by balancing this equation: 

Terrain grid size x Terrain cell size = Terrain Size 

The limitation is that the Terrain grid size must conform to one of the following values: 

16, 32, 64, 128, 256, 512, 1024, 2048 or 4096 vertices. 

Example: 512 vertices x 50 m = 25600 m; 1024 vertices x 25 m = 25600 m 

 

ArmA Series 

The sample size of a terrain (for the Satellite Image Resolution value of 1 m/1 pix) 

Terrain  

Grid, verts 

Terrain  

Cell, m 

Terrain  

Size, m 

Segment  

Size, m 

Segment  

Overlap, m 

Satellite  

Grid, cells 

Segments 

per terrain 

64 15 960 512 32 32x32 4 

128 15 1920 512 32 32x32 16 

256 15 3840 512 32 32x32 64 

512 15 7680 512 32 32x32 256 

1024 15 15360 512 32 32x32 1024 

2048* 15 30720 512 32 32x32 4096 

4096* 15 61480 512 32 32x32 16384 

*not recommended for use because of long processing 

Example: the terrain Chernarus 

Terrain  

Grid, vertexes 

Terrain  

Cell, m 

Terrain  

Size, m 

Segment  

Size, m 

Segment  

Overlap, m 

Satellite  

Grid, cells 

Segments 

per terrain 

2048 7.50 15360 512 32 64x64 1024 

 

The values of a grid cell for DEM data from the Global Data Explorer are: 

X-axis = 23.5539150311 m (~24); Y-axis = 30.8414811204 m (~32) 

After the Terrain Size is chosen, you can define the Satellite Image Resolution. This can depend on the 

quality of a map texture (Satellite Map): 1 m/1 pixel, 2 m/1 pixel, 4 m/1 pixel and etc. 

Define the Satellite Image Size = Terrain Size / Image Resolution. 

Examples: 10240 m : 1 m/pix = 10240pix; 10240 m : 2 m/pix = 5120 pix 

The five above values should be saved as they will come up again at during the creation of a terrain. 

 

7. TERRAIN EDITING 

There are several ways to edit a height map: 

• Manually (with “Surfaces (OFP)” (F9)) - you change a height of each vertex. 

• Manually In Buldozer (see below) 

• Import templates (Project > Import Templates…) 

• Import a height map (Project > Import Terrain from XYZ) – you import the file of the ASCII 

format containing space delimited XYZ on each line, where X and Y is in UTM, and Z is in meters. 



NOTE: During import you can align data to top or bottom left and set target data dimension to 

the crop data or the extend area. 

• Import PNG Image (Project > Import from Picture) - import 8/16 bit colour PNG image. 

NOTE: *.pbl file must be presented in the same location. It is automatically created when you 

export your project into *.png file via Project > Export Terrain into picture... function. 

It is possible to make a height map in V3 and then edit this in a raster V3. 

NOTE: For the terrain import (and any large scale operations like this) it is recommended to disconnect 

the Buldozer, otherwise it takes much more time to process the map. 

 

8. TERRAIN FORMATS 

The V3 allows you either to create or import the terrain. 

The existing locations can be recreated in V3 with the GIS data. 

The typical source data include: 

• The DTED or DEM elevation data 

NOTE: The V3 can't import of *.dem files. You can convert *.dem files to *.xyz files using the 

third-party software. The topic is not a subject of the manual so it will be described separately. 

• The vector data as*.vmap or *.esri shape files for roads, vegetation, and buildings 

• GeoTiff or similar bitmap surface image. 

 

Before can be used by the V3, the source data needs to be cropped to the desired size and convert into 

the following formats: 

• The Elevation Data into XYZ (ASCII triplet format). 

• The Satellite Image (Satellite Map) or other texture data as 24-bit PNG in RGB format. 

• The Vector Data as *.esri shape files. 

The terrain import formats: 

• *.xyz (the height map) 

• *.png (an height map) used with a *.pbl file (a terrain configuration) 

NOTE: Each pixel of this image presents corresponding vertex of a terrain grid. Thus, this feature 

allows you to change a terrain by resizing the image and/or setting parameters in the *.pbl file. 

To import a *.png file with *.pbl file: 

1. Project > Import Terrain from picture. 

2. Go to CA\<your_project>\Source\terrain 

3. In the folder terrain, open <your_terrain>.pbl file 

NOTE: The <your_terrain>.png have to be in the same folder for *.pbl file points to it. 

To import of *.xyz file: 

1. Project > Import Terrain from XYZ. 

2. Go to CA\<your_project>\Source\terrain 

3. In the folder terrain, open <your_terrain>. xyz file 

4. Click the Show contours button and so on 

NOTE: You can change contour range using Actual preferences tool, where it's possible to set 

both contour interval and minimum contour (in meters). 

The colors of a sea, terrain elevations and contours can be set in: 

View > Define configuration > Colors - height tab. 

The visible terrain elements can be set in View > View settings or directly by the buttons in the 

main toolbar. 



 
 

The Map Texture (Satellite Map) and Layer Mask Import 

NOTE: During import of the data the Buldozer should be disconnected from the V3. 

You need to import from Source folder the following: 

• The layers.cfg file 

• The Satellite Map (the map texture) - sm_<map_name>_lco.png 

• The Layer Mask - lm_<map_name>_lca.png 

NOTE: You can use the same file mapLegend.png for any project. 

NOTE: In Data folder the following files for each of the layer textures should be prepared: 

• <maptag>_<texture_name>_detail_co.paa - the layer texture with a normal map together 

covers area of the map texture and replaces MCO texture (if any) on close range. 

• <maptag>_middle_mco.paa - the optional texture covers area of the map texture on middle 

range. 

• <maptag>_<texture_name>_detail_nopx.paa- the normal map for the layer texture 

• <maptag>_<texture_name>.rvmat – a material for the engine 

The data have to correspond definition of so-called clutter (grass, plants or stones) generated on 

respective surface, unless the surface is overlaid by some model's Roadway LOD. 

To import “satellite map” and layer mask do so: 

1. Select Tools > Import satellite & mask command 

2. In the Select layer configuration file dialog, open the file layers.cfg 

3. In the Save .rvmat files as dialog, choose the Text item 

4. In the Select satellite map dialog, open the file sm_<map_name>_lco.png 

5. In the Select layer mask dialog, open the file lm_<map_name>_lca.png 

The Importing Satellite Data box will display the import progress. After import, the Layers folder should 

be fined in the directory P:\CA\<your_project>\Data. The segments of the map texture and of the layer 

mask and also *.rvmat files for each segment of the map texture are stored in this folder. 

NOTE: It is not necessary to delete its content when you regenerate the segments. The V3 replaces the 

changed segments. The new *.png files will be converted to *.paa files when Buldozer is started. Before 

you do so, it is recommended to save the project since it bears actual UV coordinates for the segments. 

 

9. TERRAIN IMPORT 

The map has to include an elevation data, a map texture, a layers mask, and a basic introduction to the 

features of the V3. 

1. Select Project > Open 

2. Set the File type to XYZ format and go to the folder Source in a project to open the *.xyz file. 



NOTE: It takes some time to process the file, and then a dialog will display information about the 

*.xyz file. Ensure that the properties match to your values. 

3. Click OK button 

4. Save the project to P:\CA\<project_name>\Source\<project_name>.pew 

NOTE: If you use the Save As command instead of the Save, you will need to manually append the PEW 

extension to the file name. Otherwise the file will be saved without an extension. 

 

To set the project preferences: 

1. Select Tools > Project Preferences 

NOTE: You need to only edit the preference Folder - Textures. 

2. In the field Folder - Textures put the directory CA\<project_name>\data. 

To set the project parameters: 

1. Select Tools > Project Parameters 

NOTE: This command appears when the project preferences have been set. 

2. Choose option from drop down menu Terrain grid size (a terrain resolution)  

NOTE: If a terrain is imported from *.xyz file, the Terrain grid size option displays the properties 

of *.xyz file and is locked. 

3. In the Texture Layer section, select the Base (Active) item 

4. Click the Edit button to set the area of the layer texture mapping. 

NOTE: The options are: the size of the terrain cell multiplied by x1, x2, x4, and x8. 

Example: If a size of a terrain cell is 8 m, the options are: 8x8, 16x16, 32x32, and 64x64. 

5. Click the Calculator button 

6. Enter the size of the map texture (in pixels) into the Image size (pixels) field. 

NOTE: Leave default values of the Segment size and Segment overlap. 

You will see a calculated and proposed value of Satellite Grid. 

7. Click Apply Proposed button. 

8. Click Close button. 

9. Click OK button to exit the Project Parameters dialog box. 

10. Save the project as <project_name>.pew file 

 

10. MAP TEXTURE AND LAYER MASK 

After you set the project preferences and parameters, you can import the map texture and the layer 

mask. The V3 uses value of the Satellite Grid to cut these images into the tiles that conform to rules of 

Direct X image size and will allow texture streaming: 

1. Select Tools > Import Satellite + Mask… 

NOTE: Ensure that you start in Source folder of your project. 

2. Open the layers.cfg 

3. In rvmat selection dialog box, choose Text option (if you want to reserve editable *.rvmat files) 

4. Click OK button. 

5. In Select Satellite Map window, open *.png file. 

6. In Select Layer Mask window, open *.png file. 

NOTE: The importing may take a time. The progress bar might halt but allow it to continue 

working. You can monitor actual progress by looking into Layers folder of your project where 

the V3 stores the tiles created. When the processing is done, the progress bar will disappear. 

TIP: Tune a surface with a small map first and if you are satisfied with the results, proceed with a 

large map. 

7. Save the project. 

If you want to retexture already existing map you need perform steps 2 to 7. 

 

11. TERRAIN PREVIEW WITH REAL TIME VIEWER (BULDOZER) 

Once the import finished, you can view the terrain in a real time viewer (Buldozer). 

NOTE: When Buldozer is in focus, your mouse cursor will be inactive. Use Alt+Tab keys to switch 

between Buldozer and other applications. 

1. Select Project > Connect To Buldozer 



2. Once Buldozer starts, it will call the utilities that will convert the images from PNG format into 

PAA format of Direct X compressed file. 

NOTE: Depending on the size and resolution of your map data, the process may take some time. 

When the process is completed, the command prompt window will disappear and you will be able to 

see your map in Buldozer. 

NOTE: The initial point of view will be display an area in the far northwest corner of the map, facing 

north. You might see some badly matched or stretching the map texture but this is normal since it is 

outside of an actual map area. 

In the V3 window you can click the MMB anywhere on the map to set the camera position in Buldozer 

window. 

 

12. SURFACE REPRESENTATION 

The surface is represented by a pair of the textures covering the terrain: 

• The map texture (Satellite Map) 

• The layer mask 

The textures have the PNG format. These are divided into segments when are imported to the V3. 

Each segment of a layer mask is converted to four full colors during the import process. 

The map texture provides the basic color for the terrain on far range. As a terrain can be visible beyond 

the range that objects are, the object representations are included on the surface. 

Each segment of these textures overlaps its neighbors. 

Both the layer mask and the layers defined in the configuration file determine the layer textures to 

display the surface at close range and other properties. 

The layer legend is accompanied with a configuration file, defining conversion from the RGB colors to 

layers. Configuration file defines which color represents each the layer. 

Example: Here are segments of the layer mask and of the map texture with size of 512 x 512 pixels. 

NOTE: The segments are covering the terrain from top to bottom and from left to right. 

 

Layer Mask Segment Map Texture Segment 

  
 

The layer mask is processed as an RGB image, and each pixel of the image is interpreted as following: 

• more matching color in the layer legend is found 

• based on nearest left and right basic surface the corresponding surface blend is used 

The processing the images: 

In V3 like the Photoshop: 

• Edit a map texture and save it as sm_lco.png. 

• Edit a layer mask and save it as lm_lco.png. 

NOTE: You can use either a texture type _lco or _draftlco. 

480 х 480 480 х 480 

32 32 

32 32 



In the V3: 

1. Import the map texture and layer mask 

2. Preview the result in Buldozer 

 

13. LAYER LEGEND 

The V3 uses layerslegend.png as the RGB color reference for a layer mask. 

 

A Layer Legend 

 
NOTE: This can be created using a color gradient of any image V3 such as the Photoshop. 

NOTE: The V3 uses the color spectrum of RGB color reference. You can use names of the color fractions. 

NOTE: The same layer can be represented by multiple colors which blend the layers. 

 

The Layer Mask 

 
 

The Map Texture 

 
  



 

14. MAP TEXTURE 

The map texture is a skin that covers a terrain as a set of the overlapping segments and represents a 

terrain surface. 

Cutting and overlay of the segments are controlled by a satellite grid. 

NOTE: If you experiment with the map texture and you need to regenerate it often, you may use the 

suffix _draftlco, which causes the binarization to use more fast (but less accurate) conversion of the 

generated segments to a PAA format. 

Delete _draftlco.paa content from the Layers folder if you change suffix of source raster’s to _lco. 

Each layer texture is represented: 

• At close range by a _co (color only) type and a _noxx (normal map). 

• At middle range by _mco type only. 

NOTE: To create the map texture, see the TAGorial 

Supported image formats 

For an input: 

• JPG 

• TGA (24 bit / 32 bit with alpha channel) 

• PNG (with or without alpha channel) 

• PAA 

• PAC 

NOTE: All the input images must have resolution 2
n
 x 2

n
 (e.g., 512x512). 

Largest size of the image commonly supported by BI's game engines is 2048x2048, in pixels. 

In future, a support of 4096x4096 or even larger could be possible. It is already supported in TexView 2. 

 

For an output: 

PAA/PAC A format is defined in TexConvert.cfg 

TGA 32 bit RGB format with Alpha channel 

PNG RGB format with Alpha channel 

 

15. LAYER MASK 

A layers mask is a skin that covers a terrain as a set of the overlapping segments and represents a 

placement of layer types. 

A size of a layers mask would be the same as the size of a map texture. 

Each layer within a segment of a map texture uses its own color defined in the file layers.cfg. 

This method of layer defining restricts a segment of the map texture up to four layer types. 

All four layer types can be blended together within one pixel of the layer mask, ground clutter based 

upon the dominant layer type. 

Each segment of a map texture can have up to four layer types placed within it, and each of them uses 

its own texture material defined in a *.rvmat file. 

While importing of a layer mask, all the colors convert to four basic ones. Thus, a layer mask is 

represented by black, red, green and blue colors. A color conversion is depended on a color priority. In 

the Black - Red - Green - Blue scale, a color priority increases from right to left, so the black color has the 

highest priority, and the blue color has the lowest priority. This means that the absence of the colors 

with higher priority will cause the conversion of the colors with lower priority to the colors with a higher 

priority. 

To prevent unwanted conversion of the base colors, you have to provide representation of all the base 

colors in each segment of a layer mask using a following color scheme, for example: 

 



 
NOTE: To create the layer mask, see the TAGorial 

16. LAYER DEFINITIONS 

16.1 Representing Layer Textures 

During import of a map texture and layer mask the V3 regenerates a definition of its own texture 

material for each segment of a map texture that lists the layer textures to be used. A position of the 

layer textures is defined in a segment of a layer mask, which contains the values of four base colors: 

Black RGB (0, 0, 0), Red RGB (255, 0, 0), Green RGB (0, 255, 0), Blue RGB (0, 0, 255). 

Each layer texture has its own color representation in the layer mask. The colors required for importing 

a map texture and a layer mask are set in a layers.cfg. 

The layers.cfg describes the layer mask: 

• It defines the layer textures to be used and their texture materials (RVMAT). 

• It defines a layer legend 

• It defines the color representations 

 

layers.cfg 

//Textures 

class Layers { 

  class sand { 

    texture = "ca\<your_project>\data\sand_detail_co.png"; //the layer texture 

    material="ca\<your_project>\data\sand.rvmat"; //the description of the layer texture 

  }; 

class grass { 

    texture = "ca\<your_project>\data\grass_detail_co.png"; 

    material="ca\<your_project>\data\grass.rvmat"; 

  }; 

  class city { 

    texture = "ca\<your_project>\data\city_detail_co.png"; 

    material="ca\<your_project>\data\city.rvmat"; 

  }; 

  class bed { 

    texture = "ca\<your_project>\data\bed_detail_co.png"; 

    material="ca\<your_project>\data\bed.rvmat"; 

  }; 

 

}; 

 

class Legend { 



        picture ="ca\<your_project>\Source\ layerslegend.png"; 

 

        class Colors { 

               //Colors must correspond to texture names 

                   sand  [] = {{255,255,0}}; 

                   grass [] = {{0,255,0}}; 

                   city    [] = {{0,0,255}}; 

                   bed    [] = {{99,55,0}};  

         } 

}; 

 

16.2 Segment Overlapping 

The segments of a map texture and a layer mask overlap on their edges to avoid artifacts caused by 

texture filtering. This needs to share border on the edges, for example, of 16-pixels. 

 

16.3 Covering Map Texture 

On close range the map texture is covered by the layer textures. Each the terrain cell can be covered by 

a hundred (10x10) of the instances of any layer texture at all. Therefore, actual size of a layer texture 

dependents on the size of the terrain cell. 

Example: 

Given the size of the layer texture of 1000x1000 pixels: 

• if the terrain cell has the size of 10x10 meters then each the pixel of the layer texture covers 1 

millimeter of the terrain cell 

• if the terrain cell has the size of 15x15 meters then each the pixel of the layer texture covers 1.5 

millimeter of the terrain cell 

 

17. OBJECTS 

Object Template Definitions 

To define templates you have to insert the natural and artificial P3D objects into their own panel: 

• Tools > Nature Objects 

• Tools > Artificial Objects 

Depending on the list, in which object is inserted, it will be shown or hidden when a particular filter is 

turn on/off. Clicking Add/Browse button the *.p3d objects can be inserted into lists. 

In the V3, objects exist as templates defined with name, model, ranges of random orientation and size. 

In Nature/Artificial Objects Definition window, you can change name, set properties and randomization, 

pitch and facing of an object. 

NOTE: The objects have to be deleted from the map before their templates might be deleted from list. 

 

Basic Operations 

To navigate around a map: 

• One-click MMB - point a cursor (camera) location 

• Hold down RMB - pan a map 

• Press Ctrl + J - get a cursor (camera) location 

To insert objects: 

1. Select View > Panel of Objects 

2. Select an object category from the drop down list 

3. Select an object 

4. One-click LMB on the map 

To copy objects: 

1. One-click LMB on the object 

2. Select Edit > Copy (Ctrl+C) 

3. One-click MMB to place the V3 cursor (a white square) on a map where you want 

4. Select Edit > Paste (Ctrl+V) 

NOTE: You can copy the object templates from one project into another project: 



1. Open a target project 

2. Select Project > Import Templates… 

3. In the Open dialog box, browse to a *.pew file of a source project and open it. All the object 

definitions of the source project will have entered into the corresponding lists of the target 

project. 

4. Select again Project > Open… 

5. In the Open box, browse to the *.pew file of the source project, you just imported templates 

from, and open it. 

6. In the work window of the source project, select the objects placed on the map you want. 

7. Select Edit > Copy (Ctrl+C). 

8. Go back to the target project: Project > Open… 

9. In the Open box, browse to a *.pew file of the target project and open it. 

10. One-click MMB to place the V3 cursor on a map where you want. 

11. Select Edit > Paste Relative (Ctrl+V). 

NOTE: If you copy the objects from the same map as in the target project, and you want that 

they will be placed at the same location, you need to select Edit > Paste Absolute (Shift+V). 

To edit objects and areas: 

Select object/area One-click LMB on an object/ area. 

NOTE: If you place the V3 cursor over object and press O key, 

object will be highlighted and selected in the panel of objects. 

Select objects/areas Hold down LMB and move the mouse over objects/areas. 

Add object/area to selection hold down Ctrl + one-click LMB on an object/area. 

Remove object/area from selection Hold down Shift + one-click LMB on an object/area 

NOTE: You can deselect all the objects by one-click LMB on an 

empty space. 

Move an object Hold down LMB on the object and move the mouse where you 

want. 

Open Object properties dialog box Double-click LMB on an object. 

NOTE: You can do so by one-click LMB on an object to select it 

and then press Enter key. 

 

 
 

To delete objects on the map: 

1. One-click LMB on an object 

2. Press Delete key 

Alternative way of object deleting: 

1. Start Buldozer 

2. Hover the V3 cursor (a white box) on the object 

3. One-click LMB on this object, the selection arrow (a vertical white arrow) will appear over 

object. 



4. Press Alt+Tab keys to switch from the Buldozer to the V3. 

5. Press Delete key 

 

To name object selection: 

1. Select objects 

2. Select View > Named Selections Panel 

3. One-click RMB in list of selections to open context menu. 

 

To create road type: 

1. Select Tools > Roads... 

2. Click Add... button 

3. On tab Road, name a road 

4. On tabs: Straight Parts, Curves, Special Parts, and Terminators, add new road parts 

 

 
On each the tab, click on Browse button and navigate to P:\ca\roads2 to select a road part. 

Road extensions 

Straight parts Curve parts End parts 

• _6 

• _12 

• _25 

• _10 25 

• _10 50 

• _10 75 

• _10 100 

_konec 

To place a road type on a map: 

1. In the panel of objects, select Road networks item 

2. One-click on the map 

• Type of key part - step 1: select straight part of a list 

• Click the Next button 

• Key part - step 2: select key part 

• Click the Next button 

• Parameters of key part - step 3: Key part 

• Click the Next button 

• Create key point - step 4: click the Finish button 

3. Start a building of a road 

  



 

18. BULDOZER 

The Buldozer is a real-time viewer (RTV) which connects with the V3 to render a terrain in 3D space. 

This is the engine adjusted to operating without a simulation. 

 

18.1 Setup 

You can customize RTV: 

1. Run the V3 

2. Select Tools > System Preferences to set the path to the RTV in working directory (P:\). All the 

path indications will be relative to this path. 

NOTE: If something does not work, you should check the path. 

3. Define the call parameters for RTV: 

“P:\buldozer.exe” [-window] –buldozer [-cfg=PathToConfig] -addons=\V3addons.txt 

NOTE: Commands in squad brackets [] are optional. Leave [] away when using these commands. 

 

RTV Parameters: 

-window It starts RTV in window mode instead of full screen. 

-cfg=PathToConfig It forces RTV to use a certain configuration file. 

Example: My Documents\ArmA2\ArmA2OA.cfg 

By default RTV uses Buldozer.cfg located there, but you may use 

your own configuration file located wherever you want. 

-addons=\V3addons.txt It contains a list of add-ons and configurations of them that are 

used when buldozer.exe runs in buldozer mode. 

Example: 

addons[]={"ca\", "ca\data\", "ca\UI\", "ca\UIFonts\"}; 

NOTE: 

• The path must end with backslash sign (\), otherwise it 

will be considered as file, not path. 

• This is referring to unpacked data within your working 

directory (P:\), not to *.pbo files in game installation. 

You might get error massages if your content is not 

unpacked correctly. 

• The *.txt file must be located in the root (P:\). 

-connect=pipe\<pipe_name> It creates and uses named pipe. 

NOTE: It is useful for a debugging. 

It is possible to not specify the viewer *.exe. This tells V3 it 

should only create the pipe and listen to any connections on it. 

Example: -connect=pipe\Visitor 

NOTE: 

This is useful for the external viewer launching. 

The options other than this are ignored when it is used. 

-maxmem=1024 It defines a memory amount that can be used by the RTV. 

 

The default setup parameters of the Buldozer: Tools > System Preferences … 



 
 

18.2 Control Customization 

To access controls: 

• When the RTV window is opened, press F1 

• In the main menu of a game: 

o Choose Opitons > Controls 

o In the Controls window, in the Show drop down list, choose the Buldozer controls item. 

 

18.3 Camera Control 

To connect the RTV to the V3: select Project > Connect to Buldozer (CTRL + F7) or click the red 

exclamation button (!). 

NOTE: When the RTV is started for the first time or you change any textures (regenerating surface 

segments, altering objects textures), it will convert PNG/TGA to PAA format. If application does not 

respond, let it finish its job, do not terminate it. 

To disconnect the RTV press Alt+F4 keys. 

TIP: To switch between the V3 and the RTV press Alt+Tab keys. 

 

Camera Controls 

Keyboard Mouse Description 

Insert - Switch view 

Q/PgUp - Upward move 

Z/PgDn - Downward move 

Numpad “0” - Reset view 

Numpad “2” - Downward rotate 

Numpad “4” - Left rotate 

Numpad “5” - Look free 

Numpad “6” - Right rotate 

Numpad “8” - Upward rotate 

Numpad “+” - Zoom in relative to the cursor 

Numpad “-“ - Zoom out relative to the cursor 

“Arrow UP” move forward Self-explanatory 

“Arrow DOWN” move backward Self-explanatory 

“Arrow LEFT” move leftward Self-explanatory 

“Arrow RIGHT” move rightward Self-explanatory 

NOTE: To speed an action, hold down the Shift + (one of above keys). 

  



 

18.4 Terrain Editing 

S Switch a selection type (objects/terrain). 

H Show terrain (vertex). 

T Show texture. 

U/I Raise a terrain vertex by 1 m/5 m 

J/K Lower a terrain vertex by 1 m/5 m 

F5 Magnetize points 

F6 Magnetize plans 

F7 Magnetize fixed Y 

Space Select 

 

18.5 Editing in the Visitor 3 

Select object Place the cursor over an object and then one-click LMB on it. 

NOTE: If you select objects in the RTV, they are selected in the V3 and vice versa. 

Include 

object/area 

into selection 

Hold down Ctrl key and one- click LMB on an object/area. 

Exclude 

object/area 

from selection 

Hold down Shift key and one-click LMB on an object/area. 

NOTE: You can deselect all the objects by one-click LMB on an empty space. 

Move object Hold down LMB on selected object and move a mouse. 

Rotate object Hold down Ctrl + LMB on selected object and move a mouse. 

In the RTV window, hold down RMB on selected object and move a mouse. 

NOTE: A rotation origin is defined by the cursor position. 

Up object • Hold down LMB on selected object, press Q key. 

• Hover the cursor over a selected object, keep the left Ctrl key + LMB, and move 

the mouse. 

Down object • Hold down LMB on selected object and press Z key. 

• Hover the cursor over a selected object, keep the left Ctrl key + LMB, and move 

the mouse. 

NOTE: Use Y key for European keyboard layout, instead. 

NOTE: To get an object view at night or day press N key to turn on/off FLIR filter, respectively. 

 

18.6 Editing with Buldozer 

Sometimes, it is necessary to handle edit area. This is done with the V3 in combination with RTV. 

The 2D-view in the V3 and the 3D-view in RTV are synchronized so any changes made in one will be 

transmitted to the other. 

To do so, select Project > Connect to Buldozer. 

NOTE: Your mouse cursor will disappear when the RTV window is appeared. 

• Use Alt+Tab keys to switch to other windows 

• Use Alt+F4 keys to close RTV 

When the RTV is loaded it will be display an area in the top-left corner of a window, facing north. 

 

19. DATABASE 

A project uses its own database of terrain objects. The database is divided into three categories for 

organization within the V3. 

NOTE: These categories have no impact on simulation in a game. 

The objects are local to the project. Any object is associated with its P3D model and stores additional 

information for displaying in 2D such as icon style, and values of the placement randomization. 

  



 

20. MAP CONFIGURATION 

You have to design a configuration file (config.cpp) for a terrain: 

• In the superclass CfgPatches enter a display name for a terrain that will appear in the menu of 

the map selection. 

• In the Global Position section enter UTM values for a terrain's north, south, and west extents. 

These values are embedded into the map correlation and also to set correct values for the grid 

shown in the 2D. 

• Enter the Geographic Coordinates for the south west corner in the decimal degrees 

(ddd.dddddd) rather than degrees minutes, seconds (dd mm ss.sss). This is used for simulation 

of star maps, and sun position based on the current date and your position on the Earth's 

surface. It doesn't need to be very accurate. 

• In the Surfaces section you can define up to 4 surface (layer) types for a terrain. 

Give a surface type a name with no spaces or special characters such as: grass, sand, mud, etc. 

Choose colors that will be used to represent a surface type when you create a layer mask. 

NOTE: Each surface needs a unique color. 

 

Select a base surface type to inherit from. Choose the most sensible description. 

• A surface type for grass should inherit from <tag>_land_grass_* 

• A surface type for sand should inherit from <tag>_land_sand_* 

• A surface type for mud could inherit from <tag>_land_mud_* 

You can add clutter objects to each surface type. You can edit the clutter characteristics later. 

Repeat the steps for each surface type that you want to define on a terrain. 

Save the file into the directory: <your_project>\Source\config.cpp. 

 

21. EXPORTING PEW TO WRP 

The WRP is a file format optimized for ArmA series. 

To export PEW to WRP: 

1. Ensure that the Buldozer is connected to the V3 and a terrain is visible in the RTV window. 

NOTE: Some data are handled by the Buldozer during the exporting. 

2. Select Project > Export World… and browse to a root of a project folder. 

NOTE: The file must be named the same as the project folder: tag_project.wrp. 

3. Once the export is complete, you may close the Buldozer and the V3. 

 

The *.wrp file contains the map itself. It is generated by Buldozer along with a *.hpp file. 

The *.hpp file defines map names and appearance of 2D map symbols in game. In config.cpp file, 

this is included into the class Names via #include directive or directly by a designer. The Key points 

tool in the V3 is used to insert those data. 

 

22. EXPORTING OF MAP LAYOUT 

To get a data of object placement on terrain, you can export a map as image. 

To improve visualization of objects you can do following. 

Terrain 

1. Select View > Define configuration... (CTRL+F) 

2. In tab Colors – height: 

• Set Minimal/Maximal ground height to gradient from white to 50% gray. 

• Set Color of contours to some less distinct shade. 

• Set Elevation interval style so that waterline could be used as reference for painting 

coast. It is better to entirely switch off contours or select broader interval of 10-50m. 

3. Turn off the drawing features that are not needed such as a grid. 

  



 

Objects 

When selecting vegetation, for artificial shadows of trees or painting of roads, you can use object 

symbols in the V3. 

For better selection of objects in the image V3, e.g. Photoshop, it is useful to have same color for an 

object border and its body: 

• Tools > Nature objects... – it allows adjust colors of natural objects. You may either choose the 

same color for all or use different colors for broadleaf and coniferous species. You may also use 

ellipse instead of rectangle symbol. 

• Tools > Artificial objects... - it allows adjust colors of artificial objects. You can use a position of 

artificial objects, especially when painting surfaces in cities. Some objects can be selected (e.g. 

using script) and added to selection. This allows hiding of object groups regardless of their type. 

• Tools > Roads... - it allows adjust colors of road types. 

 

22.1 Export Map as Image 

1. Select Project > Export Map as image... 

2. Choose EMF type (by default). 

3. Save the file into the folder: P:\CA\<project_name>\Source\export\images 

NOTE: It is impossible to export image in a big resolution as BMP type. 

The image resolution should be the same as Terrain size plus the size of Blue Edge, visible at the left and 

at the bottom of a map in the V3. Later the Blue Edge will be cut out. 

A width of the Blue Edge has the size of a terrain cell in pixels: 

Image size / Terrain grid size = Terrain cell size 

 

22.2 Pre-Processing of Image for Map 

You need to convert EMF to PNG type. In the V3 installation, there is utility EmfToPng.exe for the job: 

1. Copy this utility into folder containing your *.emf file (Source\export\images). 

2. Select the *.emf file and then drag-and-drop it on the EmfToPng.exe 

NOTE: In the Photoshop, you can open the PNG image of up to 40960x40960 (in pixels). 

The PNG image exported would not match a map texture by size. Therefore, you need to cut out the 

Blue Edge at the left and at the bottom of the image. 

 

23. PACKING ADDON 

To pack the terrain into PBO file, you need to have the following: 

• config.cpp 

• the header file *.hpp (if this content is not directly embedded into the config.cpp) 

• *.wrp file 

• All the textures in PAA format 

• All the *.rvmat files 

If you use your custom objects, you would pack them and add them to: 

%ArmA_installation%\@tag_addon_name\Addons\<your_objects>.pbo. 

NOTE: The BinPBO utility packs all the contents of an addon. Therefore, keep there only needed files. 

Packing Project: 

1. In the root game directory, create a mod folder, e.g. @MyMods: %game_folder%\@MyMods. 

2. In the mod folder, create another folder Addons: %game_folder%\@MyMods\Addons. 

3. Open the BinPBO: Start > All Programs > Bohemia Interactive > Tools > BinPBO Personal Edition. 

4. In the Addon source directory setting, choose the project folder, e.g. P:\TAG\TAG_MyMap. 

5. In the Destination directory setting, set the folder, e.g. %game_folder%\@MyMods\Addons. 

6. Click the LMB on the Options button. 

7. In the List of files to copy directly setting, delete the *.wrp entry. 

8. In the Path to temporary folder setting, set the folder, e.g. P:\TEMP. 

  



 

NOTE: 

• If you will pack a project again, the process would take less time than at first one, only 

changed files are converted. 

• The utility ignores some file formats and folder names by default (it does not copy them 

from a project folder into a temporary one). If you want the files to be packed, you have 

to manually copy them into corresponding directories within the temporary folder. 

9. Uncheck the check box Use source path. 

10. In the Path to project folder setting, set the directory, e.g. P:\TAG\ 

11. Click the LMB on the OK button. 

12. Click the LMB on the Pack button. 

NOTE: Wait until the Ready entry appears again at the bottom of the dialog box. 

13. After BinPBO has finished the TAG_MyMap.pbo and TAG_MyMap.log files will be placed in the 

mod folder, e.g. %game_folder%\@MyMods\Addons. 

 

24. TESTING ADDON 

Add your addon to a game: 

• In case the ArmA 2, add it via the shortcut, e.g. “%game_folder%\arma2.exe” -mod=@MyMods 

• In case the ArmA 2 OA, add it via the Expansions dialog box from the Main menu, e.g. 

• In the both cases, you can use the ArmA launchers. 

NOTE: Before placing an addon there, be sure, a game is exited. In the case, a new addon will be found 

automatically when a game is run. 

 

Testing the map: 

1. Start the game 

2. In the Main menu, press Alt/Ctrl+E 

3. Select a map 

4. Click Continue 

5. In the mission editor, select Edit in 3D world 

6. View a terrain, using W/A/S/D keys to move, Q/Z keys to up/down, and RMB to free see. 

NOTE: If you cannot see your map in the map selection, a game crashes after you attempt to preview 

mission on your terrain or you cannot see textures, check all paths in config.cpp and *.rvmat files in 

\Data folder. Make sure referenced files exist in the specified directories. 
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