
Master 

PREPARE TERRAIN 

Required software: 

• Global Mapper  

 

Digital Elevation Model (DEM) 

Selecting a DEM location: 

1. Go to the Global Data Explorer  

2. Log in (register, if you are not registered). 

3. Click the Help button on the top toolbar, and follow instructions. 

4. Download an archive. 

5. Log out 

 

Loading a DEM location: 

1. Run the Global Mapper. 

2. In the Global Mapper window, click on the Open Your Own Data Files button. 

3. In Open dialog box browse to, select and open all *.tif files suffixed with _dem (if several tiles are). 

NOTE: The program will automatically merge them. 

 

Configuring the Global Mapper: 

1. In the Global Mapper window, select Tools > Configure 

2. In the Configuration dialog box, click LMB on the Projection tab 

3. In the Projection drop-down list select UTM or Mercator 

4. Click on the OK button to close the Configuration dialog box 

 

The frame shape file is a polygon with four vertices, which outlines the terrain area, using UTM projection 

and WGS84 datum, and is stored as an ESRI shape file. This is required by the export process. 

Creating an area feature (a frame shape file): 

1. In the Global Mapper window Select Tools > Digitizer, or click LMB on the Digitizer Tool button on 

the toolbar. 

2. Click RMB on the DEM image 

3. In the context menu, select Create Area/Polygon Features > Create Rectangular/Square Area 

(Specify Coordinates). 

4. In the Select Bounds of Feature dialog box, switch to the Corner w/ Size - Global Projection (UTM - 

meters) option, and enter the values in the Width and Height field. 

The optimal sizes of a terrain (meters) using the DEM from the Global Data Explorer 

Grid 

Cell 

Terrain Grid 

16 32 64 128 256 512 1024 2048 4096 

8*      4096 8192 16384  

4      2048 4096 8192 16384 

* The values of a grid cell for DEM data from the Global Data Explorer are: 

X-axis = 23.5539150311 m (~24); Y-axis = 30.8414811204 m (~32) 

Thus, greatest common divisor of X and Y value is the value of 8. 

The alternative sizes of a terrain (meters) 

Grid 

Cell 

Terrain Grid 

16 32 64 128 256 512 1024 2048 4096 

10*    

 

2560 5120 10240 20480 

 5** 

 

    2560 5120 10240 20480 

* The values of a grid cell for a height map created by you 



** The values of a grid cell for the DEM data from the Global Data Explorer 

5. Click LMB on the OK button to close the Select Bounds of Feature dialog box 

6. In the Modify Feature Info dialog box, in the Name field, name the area 

7. Click LMB on the OK button to close the Modify Feature Info dialog box 

8. Click RMB on the DEM image. 

9. In the context menu, select Options > Show Area and Line Vertices. 

10. Find the area of interest for your terrain 

11. Click LMB on the named area to select it. 

12. Click RMB on the named area. 

13. In the context menu select the Move Area Feature item. 

NOTE: To get a better idea where your selection is located in real world: 

• Click on Download Online Data button on the toolbar. 

• In the Select online Data Source to Download dialog box, in the WORLDWIDE DATA topic, select 

OpenStreetMap.org Global Street Maps item. 

 

Elevation Grid 

You may use a frame of an real-world elevation grid as a height map for your terrain. The frame has to 

match the size of your terrain, the global coordinates of an area feature (a frame shape file). 

Exporting the frame of an elevation grid: 

1. In the Global Mapper window, select the Digitizer Tool. 

2. Click LMB on your area frame. 

3. Select File > Export > Export Elevation Grid Format 

4. In the Select Export Format dialog box, select the XYZ Grid item from the drop-down list. 

5. Click on the OK button to close the Select Export Format dialog box. 

6. In the XYZ Grid Export Options dialog box: 

• In the Options tab: 

o in the Coordinate Separator section, switch to the Space option 

o In the Resolution section, set both the X-axis and Y-axis to value of your grid cell. 

• In the Export Bounds tab, switch to the Crop to Selected Area Features option. 

7. Click OK button to close the XYZ Grid Export Options dialog box 

8. In the Save As dialog box, name and save *.xyz file 

 

Satellite Map 

You may use a frame of a satellite map as a map texture and/or a background image for your terrain. The 

frame has to match the size of your terrain, the global coordinates of an area feature (a frame shape file). 

Exporting the frame of a satellite map: 

1. In the Global Mapper window, click LMB on the Download Online Data button on the top toolbar. 

2. In the Select Online Data Source to Download dialog box, select a satellite map, for example: 

• Landsat7 Global Imagery Mosaic (Natural Color, Pan-Sharpened) 

• Landsat7 Global Imagery Mosaic (Pseudo-Color, Pan-Sharpened) 

3. Select Tools > Control Center. 

4. In the Overlay Control Center window, ensure all the layers are unchecked, except the User Created 

Features (the frame shape file) and your satellite map source. 

5. Select the Digitizer Tool. 

6. Click LMB on your area frame. 

7. Select File > Export > Export Raster/Image Format 

8. In the Select Export Format dialog box, select the PNG format from the drop-down list. 

9. Click on the OK button to close the Select Export Format dialog box. 

10. In the PNG Export Options dialog box, on the PNG Export Options tab, you may want to switch to the 

24-bit RGB (Larger Size, Full Color) option. 



11. In the Sample Spacing section, set both the X-axis and Y-axis to value of your grid cell. 

12. Ensure that Generate World File and Generate Projection (PRJ) File are selected. These files will be 

created with PGW and PRJ extensions, and should remain with your *.png file. 

13. In the Export Bounds tab, switch to the Crop to Selected Area Features option. 

14. Click OK button to close the PNG Export Options dialog box. 

15. In the Save As dialog box, name and save *.png file 

 

NOTE: Alternative software http://www.allmapsoft.com/umd/index.html  

Universal Maps Downloader is a tool that downloads tile images from Google Maps, Yahoo maps, Bing 

maps, OpenStreet Maps, Yandex Maps. 

Features: 

• Downloaded tile images are saved on your hard disk 

• You can view downloaded tile images with Maps Viewer 

• You can combine tile images into a BMP file with Maps Combiner 

Sample levels of zoom for the Maps 

Web Source Zoom Level Image Resolution Resize to 

Google 15 2560x2560 - 

16 4864x4864 4096 or 5120 

17 9472x9216 8192 or 10240 

18 18432x17920 16384 or 20480 

 

Street Map 

You may use a frame of a street map as stuff for a layer mask. The frame has to match the size of your 

terrain, the global coordinates of an area feature (a frame shape file). 

Exporting the frame of a street map: 

1. In the Global Mapper window, click LMB on the Download Online Data button on the top toolbar. 

2. In the Select Online Data Source to Download dialog box, select a street map: 

• The OpenStreetMap.org Global Street Maps option 

3. With your data loaded, select Tools > Control Center. 

4. In the Overlay Control Center window, ensure all the layers are unchecked, except the User Created 

Features (the frame shape file) and your street map source. 

5. Select the Digitizer Tool. 

6. Select your area frame. 

7. Select File > Export > Export Raster/Image Format 

8. In the Select Export Format dialog box, select the PNG format from the drop-down list. 

9. Click on the OK button to close the Select Export Format dialog box. 

10. In the PNG Export Options dialog box, on the PNG Export Options tab, you may want to switch to the 

24-bit RGB (Larger Size, Full Color) option 

11. In the Sample Spacing section, set both the X-axis and Y-axis to value of your grid cell. 

12. Ensure that Generate World File and Generate Projection (PRJ) File are selected. These files will be 

created with PGW and PRJ extensions, and should remain with your *.png file. 

13. In the Export Bounds tab, switch to the Crop to Selected Area Features option. 

NOTE: You can choose Reset to Last Exported Bounds, or enter the UTM boundary values manually. 

1. Click OK button to close the PNG Export Options dialog box. 

2. In the Save As dialog box, name and save *.png file 

  



 

Vector Data 

The real-world vector data for vegetation, buildings, roads, and other features may be used for a map 

texture, also using a satellite image, and a layer mask. 

Downloading the vector data: 

1. Go to the http://download.geofabrik.de/ 

2. Click LMB on the sub-region name to see the overview page for that, or select one of the file 

extension links for quick access. 

3. Click on the region name to see the overview page for that, or select one of the file extension links 

(if any) for quick access. In this case, [.shp.zip]. The <region name> -latest.shp.zip, yields the ESRI-

compatible shape files. 

4. Download, and Unpack the *.zip file into separate folder. 

 

Loading the vector data: 

1. In Global Mapper window, open your *.gmw project: File > Open. 

2. Select File > Open Data Files 

3. In the Open dialog box, browse and open all the *.shp files. 

NOTE: The shape files cover the whole region, not your frame area. 

4. Select Tools > Configure 

5. In the Configuration dialog box, click on the Vector Display tab. 

6. On the Vector Display tab, uncheck the Draw Feature Labels option (if it is checked). 

7. Select Tools > Digitizer, or click LMB on the Digitizer Tool button on the toolbar. 

8. Click RMB on the workspace screen. 

9. In the context menu, select Options > Hide Area and Line Vertices (if it is showed). 

 

Exporting a frame of the vector data: 

1. In the Global Mapper window, select Tools > Control Center. 

2. In the Overlay Control Center window, ensure all the layers are unchecked, except the User Created 

Features (the frame shape file) and your *.shp file. 

3. Select the Digitizer Tool. 

4. Select your area frame. 

5. Select File > Export > Export Raster/Image Format 

6. In the Select Export Format dialog box, select the PNG format from the drop-down list. 

7. Click on the OK button to close the Select Export Format dialog box. 

8. In the Sample Spacing section, set both the X-axis and Y-axis to value of your grid cell. 

9. Ensure that Generate World File and Generate Projection (PRJ) File are selected. These files will be 

created with PGW and PRJ extensions, and should remain with your *.png file. 

10. In the Export Bounds tab, switch to the Crop to Selected Area Features option. 

NOTE: You can choose Reset to Last Exported Bounds, or enter the UTM boundary values manually. 

11. Click OK button to close the PNG Export Options dialog box. 

12. In the Save As dialog box, name and save *.png file 

  



Normal Map 

Normal mapping is the technique to replace the existing normals on a 3D model. Normal maps are used 

together with the layer textures. 

Required tools: 

• Kegetys’ ArmA Tools (PAAPlug) 

• Adobe Photoshop 

NOTE: You need to have Adobe Photoshop CS6 since the current version of NVIDIA Texture Tools for 

Adobe Photoshop is compatible with this, not Adobe Photoshop CC. 

• NVIDIA Texture Tools for Adobe Photoshop (for users with a NVIDIA GPU) 

NOTE: ATI’s Normal Mapper (for users with an ATI GPU) 

 

Creating a normal map: 

1. Install PAAplug.8bi (from Kegetys’ ArmA Tools) into directory: 

C:\Program Files\Adobe\Adobe Photoshop CS6\Plug-ins\File Formats 

2. Open Adobe Photoshop 

3. Create a layer texture 

4. Save it as *.tga file with 32 bit color. 

5. Open TexView 2 (from BI Tools) 

6. Save the file as *_co.paa 

NOTE: The suffix _co means color (a diffuse map). 

7. Exit the TexView 2. 

8. In the Adobe Photoshop window, open the *_co.paa (using PAAplug). 

9. When you are asked, click 'Yes" button. 

10. In the Adobe Photoshop window, select Filter > NVIDIA Tools > NormalMapFilter 

11. In the NVIDIA Normal Map Filter dialog box, set up the settings, see: 

All Programs > NVIDIA Corporation > NVIDIA Photoshop Plug-ins > Normal Map Plug-in User Guide 

12. Click OK button. 

13. Save file as *_nopx.paa 

14. Close Adobe Photoshop. 
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