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LAYER MASK 

The tutorial helps you to quickly make simple layer mask. 

Additional software: 

• EmfToPng utility of the BI Tools 

NOTE: Copy EmfToPng.exe from directory C:\Program Files\Bohemia Interactive\Tools\Visitor 3 to 

directory %your_project%\source. 

• Adobe Photoshop (or any like this) 

 

Preparing Images 

In Terrain Editor: 

1. In the Visitor 3 window, select Project > Open 

2. In the Open dialog box, open *.pew file with your project. 

3. In menu bar, select View > Define Configuration 

4. In the untitled dialog box, in the View Settings tab: 

1) In the View settings section, set the Minimal displayed size of basic square (texture) to 1. 

2) In the Cursor display parameters section, uncheck the Show cursor in map checkbox. 

5. Click OK button. 

6. In the toolbar, select the Elevation Interval - gray scale filter 

NOTE: Make sure you selected the Show Shadows tool. 

7. Select Project > Export Map as Image 

8. Save the image as terrain_gr.emf (gray) into %your_project%\source\export\images. 

9. Option: If you create an island or a land with a coast, 

1) Select the Elevation – Color scale filter. 

NOTE: You might select Elevation – gray scale filter as alternative for. 

2) Select Project > Export Map as Image 

3) Save the image as terrain_clr.emf (Color) into %your_project%\source\export\images 

10. Exit the Visitor 3. 

 

In Picture Manager: 

1. Convert EMF to PNG with EmfToPng.exe: select the file, hover and release it on the utility. 

2. Crop the blue line on the left and bottom of the PNG image keeping its dimensions to a square. 

NOTE: If you use MS Windows, you can do this with Microsoft Office Picture Manager. 

3. Save the file cropped. 

 

In Picture Editor 

If you create an island or a land with a coast, adjust the line of the coast. 

If you use MS Windows, you can do this with the Paint picture editor: 

1. In the editor window, open the terrain_clr.png converted. 

2. In the left toolbar, select the Brush tool. 

3. In the toolset section that appear, select a round brush with biggest size. 

4. In the Color set placed at bottom-left on the window, pick a white Color. 

5. Approximately draw the coastline with this tool to crop this. 

6. Save the file edited. 

  



In Image Editor 

What you'll need to do and how many colours you will need to use will depend on what you want to create: 

• A surface covered with single layer (sand, gravel, soil and etc.) 

• A surface covered with several layers together 

 

Creating Layer Masks 

Creating a layer mask for a surface covered with single material: 

1. In the Adobe Photoshop window, in the menu bar, select File > New. 

NOTE: Make sure, the Width and Height parameters have the size of the terrain_gr. 

2. Click OK button. 

3. Select this image: Select > All. 

4. Click RMB on the image. 

5. Select the Fill item in the shortcut menu. 

6. In the Fill dialog box, click on the Use field. 

7. Select the Color item in the drop menu. 

8. In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 0, B- 0. Click OK button. 

9. In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

10. Deselect the image: Selection > Deselect. 

11. Save the image as terrain_msk1.png. 

 

Creating a layer mask for a surface covered with two materials: 

1. In the Adobe Photoshop window, open the terrain_gr.png converted. 

2. Convert this image into black-white colour: 

1) Select Image > Adjustments > Black&White. 

2) In the Black and White dialog box, click OK button. 

3. Filter the image: Filter > Filter Gallery 

4. In Artistic drop menu, select Sponge filter 

5. In the Sponge dialog box, set parameters: Brush Size - 0; Definition - 0; Smoothness - 1 

NOTE: Wait until this is done. 

6. Click OK button 

7. Select Filter > Filter Gallery. 

8. In the Sketch drop menu, select the Stamp filter. 

9. In the Stamp dialog box, set parameters: Light/Dark Balance - 25, Smoothness - 1. 

NOTE: Wait until this is done. 

10. Click OK button. 

11. Select Filter > Filter Gallery. 

12. In the Sketch drop menu, select the Photocopy filter. 

13. In the Photocopy dialog box, set parameters: Detail - 7, Darkness - 8. 

NOTE: Wait until this is done. 

14. Click OK button. 

15. Select Filter > Filter Gallery. 

16. In the Brush Strokes drop menu, select the Spatter filter. 

17. In the Spatter dialog box, set parameters: Spray Radius - 25, Smoothness - 5. 

NOTE: Wait until this is done. 

18. Click OK button. 

19. Select Filter > Filter Gallery. 

20. In the Sketch drop menu, select the Photocopy filter. 

21. In the Photocopy dialog box, set parameters: Detail - 7, Darkness - 8. 

NOTE: Wait until this is done. 

22. Click OK button. 



23. Save the image as terrain_layer.png. 

24. In the menu bar, select File > New. 

NOTE: Be sure, the Width and Height parameters have the size of the terrain_gr. 

25. Click OK button. 

26. Select this image: Select > All. 

27. Click RMB on the image. 

28. Select the Fill item in the shortcut menu. 

29. In the Fill dialog box, click on the Use field. 

30. Select the Color item in the drop menu. 

31. In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 255, B- 0. Click OK button. 

32. In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

33. Deselect the image: Selection > Deselect. 

34. Click on the tab of the terrain_layer. 

35. Select this image: Select > All. 

36. Copy the image: Edit > Copy. 

37. Deselect the image: Selection > Deselect. 

38. Close the terrain_layer. 

39. In the Untitled-1, paste the terrain_layer copied: Edit > Paste. 

40. Click RMB on the Layer 1 item at the right pane. 

41. In the shortcut menu, select the Blending Options item. 

42. In the Layer Style dialog box, within the Blend If: section, under the This Layer field, hold LMB on 

the right slider and move it onto the left end of the field to decrease the value from 255 to 0, so that 

the white colour will be deleted. Click OK button. 

43. Click RMB on the Layer 1 item again. 

44. In the shortcut menu, select the Merge Down item. 

45. Option: If you create either an island or a land with a coast, 

1) Open the terrain_clr.png edited. 

2) Select this image: Select > All. 

3) Copy the image: Edit > Copy. 

4) Deselect the image: Selection > Deselect. 

5) Close the terrain_clr. 

6) In the Untitled-1, paste the image terrain_clr copied: Edit > Paste. 

7) Select Quick Selection Tool at the left toolbar. 

8) In the Layer 1, select an area above sea level. 

9) Click RMB on Layer 1 item at the right pane. 

10) In the shortcut menu, select the Delete Layer item. 

NOTE: After the image Layer 1 is deleting, the selected area will still stay on the image. 

11) In the Background, invert the selection into outro: Select > Inverse. 

12) Click RMB on the image. 

13) Select the Fill item in the shortcut menu. 

14) In the Fill dialog box, click on the Use field. 

15) Select the Color item in the drop menu. 

16) In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 0, B- 0. Click OK button. 

17) In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

18) Deselect the image: Selection > Deselect. 

46. Save the image as terrain_msk1.png. 

  



 

Creating a layer mask for a surface covered with three materials: 

1. In the Adobe Photoshop window, open the terrain_gr.png converted. 

2. Convert this image into black-white colour: 

1) Select Image > Adjustments > Black&White. 

2) In the Black and White dialog box, click OK button. 

3. Filter the image: Filter > Filter Gallery 

4. In Artistic drop menu, select Sponge filter 

5. In the Sponge dialog box, set parameters: Brush Size - 0; Definition - 0; Smoothness - 1 

NOTE: Wait until this is done. 

6. Click OK button 

7. Select Filter > Filter Gallery. 

8. In the Sketch drop menu, select the Stamp filter. 

9. In the Stamp dialog box, set parameters: Light/Dark Balance - 25, Smoothness - 1. 

NOTE: Wait until this is done. 

10. Click OK button. 

11. Select Filter > Filter Gallery. 

12. In the Sketch drop menu, select the Photocopy filter. 

13. In the Photocopy dialog box, set parameters: Detail - 7, Darkness - 8. 

NOTE: Wait until this is done. 

14. Click OK button. 

15. Select Filter > Filter Gallery. 

16. In the Brush Strokes drop menu, select the Spatter filter. 

17. In the Spatter dialog box, set parameters: Spray Radius - 25, Smoothness - 5. 

NOTE: Wait until this is done. 

18. Click OK button. 

19. Select Filter > Filter Gallery. 

20. In the Sketch drop menu, select the Photocopy filter. 

21. In the Photocopy dialog box, set parameters: Detail - 7, Darkness - 8. 

NOTE: Wait until this is done. 

22. Click OK button. 

23. Save the image as terrain_layer.png. 

24. In the menu bar, select File > New. 

NOTE: Be sure, the Width and Height parameters have the size of the terrain_gr. 

25. Click OK button. 

26. Select this image: Select > All. 

27. Click RMB on the image. 

28. Select the Fill item in the shortcut menu. 

29. In the Fill dialog box, click on the Use field. 

30. Select the Color item in the drop menu. 

31. In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 255, B- 0. Click OK button. 

32. In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

33. Deselect the image: Selection > Deselect. 

34. Save the image as terrain_gradient_g.png. 

35. In the menu bar, select File > New. 

NOTE: Be sure, the Width and Height parameters have the size of the terrain_gr. 

36. Click OK button. 

37. Select this image: Select > All. 

38. Click RMB on the image. 

39. Select the Fill item in the shortcut menu. 



40. In the Fill dialog box, click on the Use field. 

41. Select the Color item in the drop menu. 

42. In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 0, B- 255. Click OK button. 

43. In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

44. Deselect the image: Selection > Deselect. 

45. Save the image as terrain_gradient_b.png. 

46. Open the terrain_clr.png converted. 

47.  Select Image > Adjustments > Brightness/Contrast 

48. In the Brightness/Contrast dialog box, set the parameters: Brightness - (-100), Contrast - +100 

49. Select this image: Select > All. 

50. Copy the image: Edit > Copy. 

51. Deselect the image: Selection > Deselect. 

52. Close the terrain_clr without the changes. 

53. In the menu bar, select File > New. 

NOTE: Be sure, the Width and Height parameters have the size of the terrain_gr. 

54. Click OK button. 

55. In this image, paste the terrain_clr copied: Edit > Paste. 

56. Click RMB on the Layer 1 item at the right pane. 

57. In the shortcut menu, select the Blending Options item. 

58. In the Layer Style dialog box, within the Blend If section, under the This Layer field, hold LMB on the 

right slider and move it onto the left end of the field to decrease the value from 255 so that you will 

delete some areas at will. Click OK button. 

NOTE: In addition, you can add the separate areas with another method: 

1) At the left toolbar, select Quick Selection Tool. 

2) Select areas where you want to add another layer to the mask, using the height lines. 

3) Clear the areas selected: Edit > Clear. 

4) Deselect the image: Selection > Deselect. 

59. Click RMB on the Layer 1 item again. 

60. In the shortcut menu, select the Merge Down item. 

61. Save the image as terrain_areas.png. 

62. Click on the tab of the as terrain_gradient_g. 

63. Select this image: Select > All. 

64. Copy the image: Edit > Copy. 

65. Deselect the image: Selection > Deselect. 

66. Close the terrain_gradient_g. 

67. Click on the tab of the terrain_gradient_b. 

68. In this image, paste the terrain_gradient_g copied: Edit > Paste. 

69. Click on the tab of the terrain_areas. 

70. Copy this image: Edit > Copy. 

71. Deselect the image: Selection > Deselect. 

72. Close the terrain_areas. 

73. Click on the tab of the terrain_gradient_b. 

74. In this image, paste the terrain_areas copied: Edit > Paste. 

75. At the left toolbar, select Quick Selection Tool. 

76. Select the white areas where you want to add another layer to the mask. 

77. Click RMB on Layer 2 item at the right pane. 

78. In the shortcut menu, select the Delete Layer item. 

NOTE: After the image Layer 2 is deleting, the selected area will still stay on the image. 

79. In the Layer 1, clear the areas selected: Edit > Clear. 

80. Deselect the image: Selection > Deselect. 



81. Click RMB on the Layer 1 item again. 

82. In the shortcut menu, select the Merge Down item. 

83. Click on the tab of the terrain_layer. 

84. Select this image: Select > All. 

85. Copy the image: Edit > Copy. 

86. Deselect the image: Selection > Deselect. 

87. Close the terrain_layer. 

88. In the terrain_gradient_b, paste the terrain_layer copied: Edit > Paste. 

89. Click RMB on the Layer 1 item at the right pane. 

90. In the shortcut menu, select the Blending Options item. 

91. In the Layer Style dialog box, within the Blend If: section, under the This Layer field, hold LMB on 

the right slider and move it onto the left end of the field to decrease the value from 255 to 0, so that 

the white colour will be deleted. Click OK button. 

92. Click RMB on the Layer 1 item again. 

93. In the shortcut menu, select the Merge Down item. 

94. Option: If you create either an island or a land with a coast, 

1) Open the terrain_clr.png edited. 

2) Select this image: Select > All. 

3) Copy the image: Edit > Copy. 

4) Deselect the image: Selection > Deselect. 

5) Close the terrain_clr. 

6) In the terrain_gradient_b, paste the image terrain_clr copied: Edit > Paste. 

7) Select Quick Selection Tool at the left toolbar. 

8) In the Layer 1, select an area above sea level. 

9) Click RMB on Layer 1 item at the right pane. 

10) In the shortcut menu, select the Delete Layer item. 

NOTE: After the image Layer 1 is deleting, the selected area will still stay on the image. 

11) In the Background, invert the selection into outro: Select > Inverse. 

12) Click RMB on the image. 

13) Select the Fill item in the shortcut menu. 

14) In the Fill dialog box, click on the Use field. 

15) Select the Color item in the drop menu. 

16) In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 0, B- 0. Click OK button. 

17) In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

18) Deselect the image: Selection > Deselect. 

95. Save the image as terrain_msk1.png. 

  



 

Mapping Structure 

If you want to map a structure (e.g., roads, buildings), you have to do following. 

 

In Terrain Editor: 

1. In the Visitor 3 window, select Project > Open 

2. In the Open dialog box, open *.pew file with your project. 

3. In menu bar, select View > Define Configuration 

4. In the untitled dialog box, in the View Settings tab: 

1) In the View settings section, set the Minimal displayed size of basic square (texture) to 1. 

2) In the Cursor display parameters section, uncheck the Show cursor in map checkbox. 

5. Click OK button. 

6. In the toolbar, select the Ground/Sea filter or one of next three to it. 

NOTE: Make sure the other filters are deselected. 

7. Select Project > Export Map as Image 

8. Save the image as terrain_strctr.emf (structure) into %your_project%\source\export\images. 

NOTE: Set the Resolution (XY) to a value as big as possible, for example, to 4096 (default is 2048). 

9. Exit the Visitor 3. 

 

In Picture Manager: 

1. Convert EMF to PNG with EmfToPng.exe: select the file, hover and release it on the utility. 

2. Crop the blue line on the left and bottom of the PNG image keeping its dimensions to a square. 

NOTE: If you use MS Windows, you can do this with Microsoft Office Picture Manager. 

3. Save the file cropped. 

 

In Image Editor 

1. In the Adobe Photoshop window, open the terrain_strctr.png converted. 

2. Select this image: Select > All. 

3. Copy the image: Edit > Copy. 

4. Deselect the image: Selection > Deselect. 

5. Close the terrain_strctr. 

6. In the menu bar, select File > New. 

NOTE: Make sure, the Width and Height parameters have the size of the terrain_gr. 

7. Click OK button. 

8. In the Untitled-1, select this image: Select > All. 

9. Click RMB on the image. 

10. Select the Fill item in the shortcut menu. 

11. In the Fill dialog box, click on the Use field. 

12. Select the Color item in the drop menu. 

13. In the Color Picker (Fill Color) dialog box, set the parameters: R- 0, G- 0, B- 0. 

14. Click OK button. 

15. In the Fill dialog box, set the Opacity parameter to 100%. Click OK button. 

16. In the picture Untitled-1, paste the image terrain_strctr copied: Edit > Paste. 

17. Click RMB on the Layer 1 item at the right pane. 

18. In the shortcut menu, select the Blending Options item. 

19. In the Layer Style dialog box, within the Blend If: section, under the This Layer field, hold LMB on 

the right slider and move it onto the left end of the field to decrease the value from 255 to 75, so 

that the red colour will be deleted. Click OK button. 

20. Click RMB on the Layer 1 item again. 

21. In the shortcut menu, select the Merge Down item. 



22. Select the Untitled-1 image: Select > All. 

23. Copy the image: Edit > Copy. 

24. Deselect the image: Selection > Deselect. 

25. Close the Untitled-1 without the changes. 

26. In the menu bar, select File > New. 

NOTE: Make sure, the Width and Height parameters have the size of the terrain_gr. 

27. Click OK button. 

28. In the new Untitled-1, paste the image copied: Edit > Paste. 

29. Click RMB on the Layer 1 item at the right pane. 

30. In the shortcut menu, select the Blending Options item. 

31. In the Layer Style dialog box, within the Blend If: section, under the This Layer field, hold LMB on 

the right slider and move it onto the left end of the field to decrease the value from 255 to 27, so 

that the blue colour will be deleted. Click OK button. 

32. Click RMB on the Layer 1 item again. 

33. In the shortcut menu, select the Merge Down item. 

34. Select the Untitled-1 image: Select > All. 

35. Copy the image: Edit > Copy. 

36. Deselect the image: Selection > Deselect. 

37. Save the image as terrain_strctr2.png. 

38. Close the terrain_strctr2. 

39. Open the terrain_msk1 image. 

40. In the terrain_msk1, paste the terrain_strctr2 copied: Edit > Paste. 

41. Click RMB on the Layer 1 item at the right pane. 

42. In the shortcut menu, select the Blending Options item. 

43. In the Layer Style dialog box, within the Blend If: section, under the This Layer field, hold LMB on 

the right slider and move it onto the left end of the field to decrease the value from 255 to 0, so 

that the white colour will be deleted. Click OK button. 

44. Click RMB on the Layer 1 item again. 

45. In the shortcut menu, select the Merge Down item. 

46. Save the image as terrain_msk1.png. 

 

Resizing Layer Mask 

Resize the terrain_msk1 image into the terrain size: 

1. Select Image > Image Size. 

2. In the Image Size dialog box, on the Pixel Dimensions section, set the Width and Height to. 

3. Save the image as terrain_msk2.png. 
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